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Control4 disclaimer 
Control4® makes no representations or warranties with respect to this publication, and specifically disclaims any express or implied 
warranties of merchantability or fitness for any particular purpose. Control4 reserves the right to make changes to any and all parts of this 
publication at any time, without any obligation to notify any person or entity of such changes. 

Legal Notices 
GNU 
GNU GENERAL PUBLIC LICENSE TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION (Section 3.b.) 

You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of 
Sections 1 and 2 above provided that you also do one of the following:  

Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically 
performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms 
of Sections 1 and 2 on a medium customarily used for software interchange. 

The complete text for this license is available on the Control4 web site at: http://www.control4.com.  

Gracenote 
Gracenote®, Gracenote logo and logotype, and the "Powered by Gracenote" logo are either a registered trademark or a trademark of 
Gracenote, Inc. in the United States and/or other countries. Music and DVD recognition technology and related data are provided by 
Gracenote®. Gracenote is the industry standard in Music and DVD recognition technology and related content delivery. For more 
information visit www.gracenote.com. 

MPEG 
Fraunhofer IIS and Thomson. MPEG Layer-3 audio coding technology licensed from Fraunhofer IIS and Thomson. Supply of this product 
does not convey a license nor imply any right to distribute content created with this product in revenue-generating broadcast systems 
(terrestrial, satellite, cable, and /or other distribution channels), streaming applications (via Internet, intranets, and/or other networks), 
other content distribution systems (pay-audio or audio-on-demand applications, and the like) or on physical media (compact discs, digital 
versatile discs, semiconductor chips, hard drives, memory cards, and the like). An independent license for such use is required. For details, 
visit http://mp3licensing.com. Radio Locator is the service provider of AM/FM channel list. 

Spread 
This product uses software developed by Spread Concepts LLC for use in the Spread toolkit. For more information about Spread see 
http://www.spread.org.  

All Media Guide 
© 2005-2008 All Media Guide, LLC provides music and video recognition technology that provides cover art and related text that 
enriches the Control4 user Navigators. 

Copyright and Trademarks 
Copyright ©2017, Control4 Corporation. All rights reserved. Control4, the Control4 logo, the 4-ball logo, 4Sight, Control4 My Home, and 
Mockupancy are registered trademarks or trademarks of Control4 Corporation in the United States and/or other countries. All other 
names and brands may be claimed as the property of their respective owners. All specifications subject to change without notice.  

No part of this publication may be reproduced, photocopied, stored on a retrieval system, or transmitted without the express written 
consent of the publisher.  

Contact Information 
Control4 Corporation 
11734 S. Election Road 
Salt Lake City, UT 84020 USA 
http://www.control4.com 

Part number: 200-00168-S 
Composer Professional Edition Getting Started (OS 2.10) 09/05/2017 DH 
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Introduction 
Use the Control4® Composer Professional Edition (Composer Pro) application to design and 
create projects for the Control4 system. 

Purpose 
The purpose of this document is to give Control4 dealers and Installers instructions, tips, and 
examples about how to use the Composer Pro application. 

Related documents and resources 
Document Title Location 

Composer Pro User Guide PDF: Composer Pro User Guide 
 

Control4 System User Guide PDF: ctrl4.co/userguide  

Managing Dealer Accounts 
on My.Control4.Com and 
Dealer Licensing 

PDF: http://www.control4.com/docs/product/dealer-
account/dealer-instructions/english/latest  

Composer Pro Software 
Release Update Instructions 
– 1.8.2 to 2.0 (TechDoc00012) 

Control4 Knowledgebase 

Instructional videos Dealer Portal 

Composer Pro overview 
This document is for new Control4 dealers or installers who want to learn how to use Composer 
Pro in the Control4 Operating System Release 2.10 (OS 2.10) or later, or for those who want to 
keep up with the latest changes. If you are already familiar with Composer Pro, you may only 
want to know what has changed from the last release. If this is the case, see “What’s new in this 
release” or “Where to go from here” for more advanced information about Composer Pro, and 
then search for your subjects in the Composer Pro User Guide. 

The Control4 system is a combination of Control4 and third-party controllable devices, for 
example, HDTVs, DVDs, CD players, speakers, home theaters, lights (and so on) that 
communicate with one another via TCP/IP, infrared (IR), serial, contact, or relay connections. 

Composer Professional Edition (Composer Pro) is the software application that Control4 dealers 
and/or installers use to design and set up a Control4 system project for home automation in a 
consumer's home or business. The software runs on either a Windows 7, 8, or Windows Vista 
computer, and provides a powerful graphical interface for object-based programming. When 
connected to a Control4 controller, the project's information is then communicated to Director on 
the controller. Director, in turn, uses the configuration information and device drivers to 
communicate to the devices in the home automation system. 

Note: Composer Pro 2.6.0 and above is not compatible with Windows XP 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
http://kb.control4.com/
http://dealer.control4.com/
http://http/www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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The sections in this Getting Started document provide basic information and steps for Control4 
dealers and installers to become familiar with and start using the Composer Pro interface for 
initial design and setup of a Control4 system. 

Information beyond the basics described in this guide (for intermediate and advanced users of 
Composer Pro) is provided in the Composer Pro User Guide. 

Setting up the Control4 system—overview 
Setting up a fully functional Control4 system includes the following major procedures. 

For best results, Control4 recommends that you follow the procedures in this order: 

1 Install and connect the hardware—When deploying a Control4 system, install and connect 
the essential devices:  
• A Control4 controller (for example, an EA-3) 
• A Windows-based computer to set up and configure the home automation system using 

Composer Pro 
• The device to be controlled (for example, touch screen, DVD player, speakers, lights, 

Dock for iPod, etc.) 
• A controller and PC connection to the home network  

2 Purchase the required licenses—To use Composer Pro for your company or your 
employees, you’ll need to purchase and assign licenses. See the document Managing 
Dealer Accounts on My.Control4.Com for details. 

3 Install the Composer Pro software—Use the Composer Pro installation software to install 
Composer on a PC and activate it using your my.control4.com dealer user account. 

4 Connect to a Director— Each time you start Composer on your PC, you either connect to 
Director running on a local or remote controller (live connection) or a virtual Director running 
on your PC (virtual connection). Director is the software on a controller that stores the 
Control4 system configuration and manages the control of each subsystem and device in 
the Control4 system. 
• Live connection: To make changes to a Control4 system in real time, connect to the 

Director through either Local System (over the home network) or Remote System (over 
the Internet).  

Note: Remote Access must be configured locally before using a remote connection to 
the controller. See “Setting up Remote Access.” 

• Virtual connection: Alternatively, to create or edit the system configuration offline and 
save the project file, connect to Director through Virtual System. The saved .c4p project 
file can be loaded later into a controller through a local connection to ensure that 
Director has the updated system configuration. 

5 Plan and design the system. To design a system in Composer Pro, you first create a 
project in the form of a project tree that represents the hierarchy of locations for the devices 
to be automated in the home-automation system (site > building > floors > rooms > devices) 
and the devices that reside in each room.  
• Create a plan. Creating a plan before you start your project in Composer Pro will help 

make your system design go much more smoothly. 
• Design the system using System Design view: Use the System Design view where 

you can view the project tree as you build the design. 
6 Make and test the connections. In the Composer Pro project, you must define all of the 

physical connections of the devices to the system: control (IR and serial)and AV (audio, 
video). You must also define other connections: room control and network connections. You 
can use Composer Connections view to complete the connections. 

7 Register the system. Control4 recommends that you register each system you install at 
customer.control4.com to maintain the system software through software updates and 
critical system patches. 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
http://www.control4.com/docs/product/dealer-account/dealer-instructions/english/latest
http://www.control4.com/docs/product/dealer-account/dealer-instructions/english/latest
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Important: Only registered systems can use all of the media services available. System 
registration is one of the essential steps that lets you access the system remotely (remote 
access) for repairs, updates, and additions. 

Composer Pro system requirements 
Computer software and hardware 
• Microsoft.NET 4 (the Composer install is launched automatically from the Control4 website). 
• Microsoft operating systems supported (Windows 10, 8, 7, or Vista). Mac support when used 

with a Windows virtual machine such as Parallels or VMWare Fusion for Mac. 
• 500 MHz or higher processor 
• 256 MB RAM 
• 90 MB available hard disk space 
• Video card and monitor supporting a resolution of 1024x768 or higher 
• Keyboard 
• Mouse 
• 1 to 2 Ethernet (CAT5 or CAT6) cables 

Home computer network 
• Wireless access point (WAP) or wireless router that supports 802.11 b/g/n (optional) 
• TCP/IP-based (Ethernet) home network. This usually includes a network gateway, router or 

switch. 
• 1–2 Ethernet (CAT5 or CAT6) cables 
• A broadband Internet connection. During initial setup, a broadband Internet connection is 

required to update the Control4 system and retrieve the media's cover art. Also, a 
broadband Internet connection is required to support remote access to the system. 

Control4 home automation network  

• A Control4 controller (for example, an EA-3). 
• Control4 Composer Professional Edition (Composer Pro) software, version 2.10. 
• Note: A Control4 controller is set by default as a DHCP client. If the home network has a 

DHCP server in place (for example, a router that provides DHCP services), then the 
controller automatically receives a valid IP address. 

Note: Control4 recommends that you update to the latest software release. 

• A wireless access point (WAP) that supports 802.11b/g/n (required to use a Control4 
wireless touch screen). 

• A valid electronic license to run Composer Pro. Control4 now requires activation using a 
my.control4.com account with a license to run Composer Pro. Re-activation is required 
every 30 days. See Managing Dealer Accounts on My.Control4.com on the Control4 dealer 
website or Knowledgebase to learn how to add and manage licenses from my.control4.com. 

http://www.control4.com/docs/product/dealer-account/dealer-instructions/english/latest
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Installing the hardware and software 
This section provides guidelines to install the devices and Composer Pro. 

Installing and connecting the hardware 
Before you can set up a Control4 home automation system in Composer Pro, all of the devices to 
be used in the system need to be installed and connected to the home network. Additional devices 
can be added and identified to the Composer Pro project if you install or replace devices in the 
future. 

Follow these guidelines to get started: 

1 Create a system specification, and refer to it so you can answer these questions. 
a What does the home have? 

• Any there any outer buildings, for example a detached garage, that will be 
automated? All buildings to be automated must be included in the project. 

• How many floors are there in each building? For example, the house has three 
floors and a basement; the garage has one floor. 

• What rooms are on each floor? For example, the third floor of the house has one 
Master Bedroom and two other bedrooms. The third floor also has one Master Bath 
and one Main Bath. 

b Which Control4 devices are or will be installed in each room (include manufacturers and 
model numbers)? 

c Which third-party devices are or will be installed in each room (include manufacturers 
and model numbers)? 

d If any of these devices has a choice of power sources, indicate how the device will be 
powered: AC, DC, or batteries. 

e If any of these devices has communication options, indicate how each device will 
communicate with the controller (how the device will be controlled): Ethernet, Power 
Over Ethernet (POE), WiFi, ZigBee® Pro, IR, serial, contact, or relay. 

2 Install and connect the Control4 devices as described in the installation or setup guide that 
ships with each device.  

Tip: See also “Related documents and resources” in this guide for document locations. 

3 Install and connect all third-party devices, for example, audio-video devices, door contacts, 
and security panels, as described in the installation guide that ships with each device. 

4 Connect the Control4 controller and your PC to the home network using an Ethernet 
connection. A simple Control4 system and home network are shown below. 

  



Composer Pro 2.10 Getting Started Guide  

9 

 

• Use the RJ-45 jack labeled ‘Ethernet’ on the back of the controller to connect it to the 
home network. If successful, the amber LED turns on and the green LED blinks. Read 
the controller’s installation guide to learn how the LEDs work. 

• Use either a wireless access point (WAP) or Ethernet cable to connect the PC to the 
home network.  

5 Confirm that the Control4 devices are getting network addresses from the gateway, router, 
or switch. See the Composer Pro User Guide for details. 

Installing Composer Pro software 
Follow these steps to install your Control4 Composer Pro software for the first time. If you are 
upgrading from a version earlier than OS 2.5.3, you must first upgrade to OS 2.5.3 to continue. 
Please refer to the specific version of this document for further information. 

Note: An Internet connection is required to perform this installation. 

Follow these general steps for existing systems: 

• For dealer licenses, purchase, install and activate the licenses. The computer running 
Composer Pro must be connected to the Internet, and the installer must have a 
my.control4.com account with a license to run Composer Pro. Activation is required every 30 
days. See Managing Dealer Accounts on My.Control4.Com on the Dealer Portal. 

• Install Composer Pro.  
• Register the system and the controller. 
• Use Update Manager to upgrade to OS 2.10. 

To install the Composer Pro software: 

1 Obtain the Composer Pro Installation software (available as web download from the Dealer 
Portal). 

2 Start the Composer Pro installation, and then follow the on-screen instructions. 

Tip: You can read the Release Notes at this time, too, if you check the box during setup. 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
http://www.control4.com/docs/product/dealer-account/dealer-instructions/english/latest
http://dealer.control4.com/
http://dealer.control4.com/
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3 Select to update to the latest version of Composer. 

Note: The Composer version or drivers are updated after the creation of the CD, USB drive, 
or web download. However, Control4 recommends that you always select to update. 

Tip: As new features and drivers become available, the Composer Pro software and 
associated drivers can be updated. When installation is completed, you can update from the 
Tools menu, Windows Start, or by running the installation. 

4 During the installation process, click Continue Anyway to allow the installation to proceed. 
5 The next screen asks for your dealer account login and password. This assumes that you 

already have an account on my.control4.com. If you don't have an account, click Don't have 
a dealer account yet? to get one; otherwise, click Register. 
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Exploring Composer Pro features 
The Control4 Composer Pro interface (views) and wizards are designed to help you simplify the 
process of designing the system, identifying and configuring the devices, making the 
connections, and then customizing the system through programming. How you set up the 
devices in Composer Pro determines how they function in the system. 

First page 
When you start Composer Pro and connect to a Director, a similar screen like the following 
System Design view appears:  

  

The Composer Pro interface contains menus, panes, a project tree, tabs, and objects. These 
components are explained in this document. 

Composer Pro startup options 
Start Composer Pro 

You can start the Control4 Composer Pro application two ways: 

• Double-click the Composer icon on your desktop (easiest way). 
• Click Start > All Programs > Control4 > Composer 2.x.x > Composer 2.x.x. 
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Tip: For your convenience, in Composer 2.5 and later the Start menu also displays your 
projects, logs, and drivers. 

 

When you start Composer Pro, the Composer startup screen displays:  

 

This screen presents the following Director-connection options. Click one of the options to 
access the Composer Pro project and project tree (System Design view). 

• Virtual System—Click this option to work on the project when you are disconnected from 
the network. If you do not have access to the controller, you can still set up a system using a 
“Virtual” Director on your PC, and upload your changes later to the controller. Using a virtual 
connection, you can complete most design tasks, including making software connections 
and performing some programming tasks. You cannot identify network connections, test 
device control, or set up media virtually in this mode, however.  

Note: Use this option, for example, if you are installing Centralized Lighting products. Also, 
check Install the Report Viewer to add the Centralized Lighting reports. Your electrician will 
need these reports to install the panels and modules when they become available. See the 
documentation, plans, and videos on the Control4 website. 

• Local System—Click this option if you have a direct connection to the home network (inside 
the firewall). This option gives you all the capabilities of the application: set up and design a 
project, connect the devices to the network, configure the media, and program the system. 
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• Remote System—Click this option to work from a remote location by establishing an 
Internet connection to the home network (outside the firewall). You can perform the same 
tasks as if you were connected using the Local System option. 

• System Manager—Click this option to launch System Manager. System Manager can also 
be launched from Tools > System Manager, or from the Composer folder in the Windows 
Start menu.  

This Directors dialog appears only when you click Local System. In this case, you select the 
network address associated with the controller, and then click Connect. 

 

• Connect—Lets you connect to the Director that resides on the controller attached to the 
local network. 

• Cancel—Cancels and closes the Directors dialog box. 
• Add—Lets you add the Director’s address of the controller to which you are trying to 

connect. 
• Remove—Lets you remove the selected Director from the list. 
• Refresh—Lets you update the Directors list to display recently-added Directors. 

Exit Composer Pro 
You can exit Composer two ways: 

• Startup window (where you start Director):click Exit Composer. 
• File menu (in the Composer project): select Exit. 

As you exit, Composer Pro prompts you to back up your project and media information to your 
local computer. This is not required except when using a Virtual System connection, but Control4 
highly recommends that you back up your project every time you close Composer Pro. 

Composer Pro views 
Available views 

The Control4 Composer Pro application has five main views (buttons are located in the bottom 
left pane). When you select a view (see the figures below) the appearance, functionality, and 
configuration change for that view. 
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Also note the status bar at the bottom of the screen, which indicates the Director’s network IP 
address and Director status. 

Tip: Collapse the views by clicking the dotted bar just above the views so you have more room 
to view the project tree. 

Main menu: 

 

Composer view buttons: 

 

Click one of these buttons for the desired view. 

• System Design—Build the project tree by adding locations and devices and define 
device properties. 

• Connections—Make connections in the project between devices (Room, Control, AV, 
Network) and identify devices.  

• Media—Add and scan stored or broadcast media. 
• Agents—Set up an agent for use in the system and in programming. Agent types: 

Lighting Scenes, Wakeup, Scheduler, Variables, etc.  
• Programming—Program events and actions to automate the system. Using  

predefined events and user-defined agents. 
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System Design view 
Use the Control4 Composer Pro System Design view (the default view when you start Composer 
Pro) to define the Control4 system project for a customer.  

This view lets you set up the project tree by defining 

• The location of the devices to set up in the project (building). 
• The device you want to include in the project (device objects). 
• The location of each device by room (room).  

To access the System Design view: 

1 Start Composer.  

Take note of the three large panes in the screen below (System Design, Properties, and 
Items): 

 

• System Design (left pane)—Contains the project tree where you build or update the 
project configuration with locations and device drivers. Select the room where you want 
the device driver to go, and then double-click a device driver in the Items pane (right 
side) to add it to the project tree. 

• Properties (center pane)—Contains the Properties of the object you select from the 
project tree when you want to check or modify a device, project, and room. Refer to the 
sections below to view more information about the Properties pane. 
• “Project Properties” 
• “Room Properties” 
• “Device Properties” 
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• Items (right pane)—Contains the items (or objects, device drivers) you use to build 
your project, such as locations (sites, buildings, floors, rooms) and devices (controller 
hardware, DVDs, TVs, receivers, lights, contacts, relays, etc.). If a device is not 
available in the My Drivers tab in this pane, use the Search tab to search for that device 
(see the Composer Pro User Guide for information about how to search for drivers). If 
you've created a new driver using the Driver Wizard or DriverWorks, you will find your 
new driver in the Search tab. 

System Design pane 
The System Design pane in the System Design view displays the project tree. You build the 
project by adding floors, rooms, and devices from the Items pane to the tree. 

To access the System Design pane: 

1 Start Composer. 

Note: The example project tree below shows the project name (Main), site (Home), building 
(House), floors (Main), rooms (Family, etc.), and the devices already added to the project. If 
your project is new, the pane will show only the New Project icon and item. Rename your 
project by right-clicking the name and selecting Rename.  

 

Use the project tree to: 

• Add Locations—Lets you add locations (sites, buildings, and floors) to the project tree. 
Double-click to select an item from the Items pane > Locations tab to move location 
items to the project tree. If you do not manually add the locations, Composer 
automatically adds generic locations. 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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• Add Devices—Lets you add devices (lights, VCRs, TVs, controllers, etc.) and their 
device driver to the project tree below the selected room. To add devices, click the 
location (where the device is installed) in the project tree, and then double-click a 
device in the Items pane > My Drivers or Search tabs (right pane) to move device to 
the project tree. 

• For more information about how to create a project, see “Introduction.” 

Project tree search, sync, and filter 

To make it easier to find and manage devices in large projects, the project tree has search, sync, 
and filter controls. 

 

• Search—Type the device name to search for here. Click the Find Next button to jump to the 
next device of that name. Click the down arrow on the right side of the search box to select 
from previously used search terms. 

• Sync—Use Sync to keep the same project device selected while switching between System 
Design, Connections, and Programming views. Click the Sync button and select the 
checkbox for the views you want to keep synchronized with the System Design view, then 
click Done. To clear them, click the checkboxes or click Clear All. 

 

 

• Filters—Use filters to hide or show only certain types of items in the project tree. Click the 
Filters button, then set filters by Device Type or Category. The Device Type list contains 
only device types already included in your project. Setting a filter under Device Type will 
clear any filters already set in Category, and vice versa. To clear all filters, click Clear All 
Filters. 
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Device Control window 
The Device Control window in System Design lets you test and control a physical device (after 
identifying the device and making its connection) in Composer Pro to make sure it works in the 
system. 

Note: You must define the connections before you test or control the devices. See “Testing the 
device connections” for information about how to make the connections.  

Example: To use the Device Control for a dimmer, you click a button in the Device Control 
window to turn the dimmer on or off and change the light level. If the physical light changes also, 
you know the dimmer driver is added and the basic connections are made correctly. 

To access the Device Control window: 

1 Start Composer. The System Design view appears. 

Double-click the device in the project tree to access the Device Control window (see below) for 
that device. 

 

This window lets you change the configuration parameters (temporarily) and control a device. 
Later, you can set the parameters permanently in the Properties pane or Programming view. 

Example: You can adjust and test the ramp rate of a dimmer to determine the desired ramp rate 
to set during programming. 
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Properties pane 
In the System Design view, click the project name (“Main,” in this example) in the project tree to 
view the Properties pane (center pane). 

 

The project Properties appear when you first start Composer Pro, or any time you select the 
project name (or root node) in the project tree. Different properties appear depending on the item 
you select.  

  

This option lets you enter project-specific information; for example, the project name, location, 
and ZIP Code. Composer Pro automatically enters the latitude/longitude and date/time 
information after you provide the location and ZIP Code. 



Composer Pro 2.10 Getting Started Guide  

20 

Properties Pane 

Project Settings tab 

Category Boxes or Buttons 
Project Name—Lets you 
enter/edit the name of the 
project. 

N/A 

Location—Lets you look up a 
location’s latitude and 
longitude based on city, state, 
country, etc. 

Latitude/Longitude—Lets the system calculate from the entered ZIP 
Code, the local latitude and longitude coordinate information. Knowing 
location information lets the system calculate local sunrise and sunset 
times. This is useful for programming lights to turn on at dusk and off at 
dawn. Using a ZIP Code to find the coordinates only provides a close 
estimate of latitude and longitude. If you want to enter exact coordinates, 
the fields can be edited. Also used for outside temperature on the touch 
screens. 
Country—Lets you select the country in which the project is located. 
Lookup Button—Lets you enter/edit the ZIP Code which identifies to the 
system the local cable, satellite, and broadcast channel programming. It 
also automatically provides latitude and longitude coordinate location. 

Date and Time—Lets you set 
a date, time, and time zone for 
the Control4 system. By 
changing the time here and 
refreshing Navigators (File > 
Refresh Navigators), you reset 
the time on the entire system. 
However, Control4 systems 
with access to the Internet 
automatically synchronize the 
system clock using Network 
Time Protocol (NTP). 

Timezone—Lets you set the appropriate time zone by clicking Edit. 
Changing the time zone causes the controller to reboot. 
Display time using a 24-hour clock—If checked, lets you use the 24-
hour clock (0 to 2400 hours) rather than 12 am to 12 pm. 

Project Settings Control—
Lets you set a device in 
Composer that does not allow 
the setting to be overridden at 
the device. 

Push Settings From Project—Check the box for devices to receive 
settings from the Composer project only. New settings in the Composer 
project override any settings at the device. 

System Security—If set, all 
Navigators (Release 2.0 or 
later) must connect through a 
secure connection. 

Properties Pane: Information tab 

Localization—Lets you set 
the locale and character set 
for countries outside the 
United States. 

Locale—Use the down arrow to change the locale.  

Scale—Lets you select the 
temperature type. Fahrenheit or Celsius. 

Information tab 

Category Boxes or Buttons 

System Owner Name, Address, Phone, and Email—Enter homeowner information into 
these fields. 

Dealer Information 
Name, Address, Phone, Email, Primary Contact, Lead Installer, 
Original Install Date, and Date of Last Update—Enter dealer 
information and project update dates into these fields. 

Project Notes Any notes the dealer wants to add can be stored here. 
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Lighting Defaults tab 

Category Boxes or Buttons 

Lighting Defaults—Lets you 
set default LED colors for 
switches, dimmers, and 
keypads as well as certain 
default parameters for 
Centralized Lighting. You can 
still modify these settings for 
individual devices in the 
device properties. Also lets 
you set basic parameters for 
Centralized Lighting. 

On Color/Off Color—Set the default On and Off color for each LED in 
the project.  
Centralized Modules in Control4 Panel—Select this box to indicate 
that the Centralized Lighting modules will be installed in Control4 2-Slot 
or 5-Slot Panels. If the modules will be installed in off-the-shelf DIN Rail 
panels, leave this box unchecked. 
Centralized Modules Use Arc Fault Breaker—Select this box if the 
majority of Centralized Lighting modules will be connected to an arc-fault 
breaker (AFCI). 
Nominal Voltage—Select the default voltage that will be used by the 
Centralized lighting modules.  

Lighting Defaults tab 

Category Boxes or Buttons 

Subnets 

By default, it is not possible to identify a device that resides on a different 
network (e.g., subnet) because Director actively excludes identification 
broadcasts received from devices on a different network.  
 
You can expand the list of allowed networks by adding one, or more, 
CIDR network specifications to the following list.  
 
For example: 
    192.168.2.0/24 
 
For more examples see: ( <https://en.wikipedia.org/wiki/Classless_Inter-
Domain_Routing>) 

ZigBee Configuration tab 

Category Boxes or Buttons 
Edit Zigbee Configuration Click on this link to define, edit, and move ZigBee mesh configurations. 
Refresh Click on this link to refresh the ZigBee status view below. 

ZigBee Network Status 

Use this view to see the status of the ZigBee mesh(es) in your project.  
Name—Name of the device configured in the ZigBee mesh. 
Controller Status—The colored icon shows an at-a-glance status of the 
ZigBee network. Green for online, Yellow for offline, Red for error. 
ZigBee Server—The controller defined as the ZigBee Server will say 
“Enabled”. 
ZigBee Status—Shows the status of the ZigBee Server. “Running” 
means the ZigBee Server is configured and running. 
Channel—The current channel of the ZigBee mesh. 
ZAP Status—A controller configured as a ZAP will show as 
“Coordinator” or “Enabled”. 

Z-Wave Configuration tab 

Category Boxes or Buttons 
Advanced Use the Learn, Network Update, Reset Defaults, and Send Node Info 

buttons to manage your Z-Wave network. See the Z-Wave Setup Guide 
for more information (ctrl4.co/z-wave-sg) 

 

http://ctrl4.co/z-wave-sg


Composer Pro 2.10 Getting Started Guide  

22 

Room Properties 
The room Properties (System Design > Room > Properties) appear when you select a room in 
the System Design project tree. 

 

The room Properties pane lets you view room-specific device and media information (for 
example, the iPod  located in the Office is an available audio source in the Family room), and 
helps you troubleshoot any incorrect room connections. 

The Audio/Video Devices tablets you view the devices configured for each end point device 
and the devices that are available in the room. 

Example: If you can’t play movies from a Disc Changer in a particular room, you can view the 
room’s Properties to see if the disc changer shows up in the List view. If it does not, you are 
probably missing AV bindings in the path to the device. Detailed information about connections is 
available in the Composer Pro User Guide, or see “Connections view.” 

 

Properties Pane—Room Properties 

Category Box or Button 

Audio Video Devices tab—Provides 
information that lets you view all audio and 
video devices and control connections in a 
selected room. 
  
  

Audio Endpoint—The device that is configured to play 
audio in the room. 
Tip: Which device needs to turn on and off to listen to any 
source of audio in the room? 
 
Audio Volume—The device that is configured to control 
the audio volume in the room. 
Tip: Which device do you need to send volume commands 
to in order to control the audio volume in the room? 
  
Video Endpoint—The device in the room that is configured 
to display the video in the room. 
Tip: Which video display device is in the room, or where 
does the video end up? 

Navigator tab—Lets you hide and re-order 
device visibility for all Navigators (in Watch, 
Listen, etc.). 

Modify—Lets you move the order of devices up or down, 
and hide or show them. Select the device in the Menu list. 
 
 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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Properties Pane—Room Properties 

Category Box or Button 

  
Miscellaneous view—Lets you set the 
default audio and video volume for the 
room, for example, what the room will revert 
to after a power cycle. This is also where 
you set the IR Mask for the room. 
 

Enable Default Volume—Select and use the up or down 
arrows to change the audio and video volume. 
 
Mute When Paused—Select this option to send a mute 
command when media is the room is paused. 
 
Multi-Room Shared IR Settings—Use the down arrow to 
select the IR. 

Device Properties 
The device Properties (System Design > device > Properties) are visible when you select a 
device in the project tree. This option lets you modify the available (if any) user options for the 
selected device. 

 

 

Properties Pane: Device Properties 

Category 
Properties—Lets you modify options (if available) that are common to all devices of that type. 
 
Advanced Properties—Lets you modify advanced options (if available) on some devices. 

List View pane 
Use the Control4 Composer Pro List View pane in System Design to view all of the devices in a 
room. 

When you select a room or any device in a room in the project tree, and then click List View, all 
of the devices installed in that room display; for example, notice all of the devices installed in the 
Family room (shown below). 

Note: The List View shows all the devices in a given area and the current state of contact inputs 
or other devices. When selecting the site, building, floor, or room, all of the devices associated in 
that area are visible. If a single device is selected in the project tree, List View shows all devices 
that are in the same room. 



Composer Pro 2.10 Getting Started Guide  

24 

 

To access the List View pane: 

1 Start Composer. 
2 In the project tree, click any object. 
3 In the Properties pane, click the List View tab. 
4 You can double-click a device in the List View pane to display its Device Control window. 

Items pane 
The Control4 Composer Pro Items pane lets you build the project tree either by: 

• Dragging and dropping items from the Items pane to the project tree, or by 
• Double-clicking the item in the Items pane (which adds it to the project tree). 

Note: In OS 2.3.0 or later, specific devices can be added and identified in the project tree 
automatically using the Discovered tab (via SDDP). See the figure below and the Composer Pro 
User Guide for details. 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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To access the Items pane: 

1 Start Composer Pro. The System Design view appears by default. 
2 View the Items pane on the right side. 
3 Click the Locations tab.  

 

The Locations tab displays the list of available objects by their physical location in the home 
(site, building, floor, or room) that you can add to a project. Use the items in the Locations 
tab to organize the project tree by area.  

Example: The Sites object shows which sites (Home, Work, Corporate, etc.) you can add to 
your project tree as you begin to build your design.  
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4 Click the Discovered tab. 

 

The Discovered tab (supported for devices added in OS 2.3 and later) lists the devices that 
can be automatically discovered by the system. You simply click where in the project (room) 
you want the device to go (left pane), and then double-click the device in the list; it will be 
added and identified automatically. See “Configuring devices” in the Composer Pro User 
Guide for details. This feature is ideal for smaller systems. 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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5 Click the My Drivers tab. 

  

The My Drivers tab displays a list of device drivers you can add to the project tree. This is a 
list of common Control4 and third-party device drivers. If you can't find the driver you want, 
go to Step 6. 
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6 To locate a driver that is not in the common list, click the Search tab. If you can't find the 
driver you want here, you may need to create your own driver. See “Search tab” for details 
about how to use the Search function.   

  

The Search tab lets you search for drivers that don't appear in the My Drivers tab. 
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My Drivers tab 
Use the My Drivers tab to add Control4 and popular third-party device drivers to the project tree.  

 

To access the My Drivers tab: 

1 Start Composer Pro and connect to a Director. 
2 In the project tree, click the room to add the driver to. 
3 In the Items pane (right side), click the My Drivers tab. A list of devices appears. 
4 Click to expand a category, and type in the search box to search for a device name. 
5 Double-click a device driver in the list to add it to the project tree. For information about 

configuring devices after adding them to the project tree, see "Configuring devices" in the 
Composer Pro User Guide. 

6 The My Drivers list is only a set of common devices. If you do not see the device driver you 
need, you can find and add device drivers to the My Drivers list using the Search tab.  

If you select a generic device, a dialog box with a list of devices appears. Select a specific model 
to add it to the project tree. If you can't find the device driver you need, you can either modify an 
existing one or create a new one. See the Composer Pro User Guide for details. 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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My Drivers options 
If you right-click any device driver in the My Drivers list, the following options display: 

 

• New Folder—Create a new folder in the My Drivers list. 
• Rename Folder—Rename an existing folder. 
• Collapse Folders—Close all folders. 
• Expand Folders—Open all folders to expose the items. 
• Add Driver—Add a driver to the My Drivers list.. 
• Delete—Remove an existing driver from the My Drivers list. 
• Move Up—Move the item up the list. 
• Move Down—Move the item down the list. 
• Save List—Save the My Drivers list. 
• Load List—Load a saved list. 
• Add from Defaults—Add a driver from the default list. 
• Restore Default List—Restore the device list to the default contents. 

Search tab 
Use the Search tab to search for and add device drivers to the project tree that do not appear in 
the My Drivers list. 

To find a device driver using Search: 

1 Start Composer Pro and connect to a Director. 
2 In the project tree, click the room to add the driver to. 
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3 In the Items pane, click the Search tab. 

  

To find a device driver: 

1 From the project tree, select the room where the device resides. 
2 In the Search tab, type the text to search for in the search box. As you type, matching 

options are displayed. 
3 To narrow down the search, select the device type and the manufacturer from the respective 

filters. 
4 Drag the driver to the project tree, or double-click the device driver to add it the project tree. 

• [search text field]—Type the text to search for here. You can use the drop-down menu 
to select terms that were previously typed. 

• Local (default)—The Local checkbox lets you view device drivers stored on your local 
computer. 

• Online—The Online checkbox lets you view and download drivers from the online 
database. 

• Certified Only—This checkbox specifies that only Control4-Certified drivers will appear 
in the search results.  

• Device Types—Lets you select the device type (proxy), for example, AV Switch 
(includes audio switches), Blinds, CD, Disc Changer (includes DVD and CD Changers), 
DVD, Light, Receiver, Satellite (includes DVRs), Cable TV, Television, Thermostat, 
Tuner, VCR and more.  

• Manufacturers—Lets you select the manufacturer. 
• Sort by—Lets you select the order that search results are displayed. 
• Results—Detailed search results appear, including the manufacturer, model, and driver 

location. 
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Locations tab 
Use the Locations tab to add the list of available locations (site, building, floor, room, etc.) to a 
project. 

To access the Locations tab: 

1 In the project tree, click the site, building, or floor where you want to add the location. 
2 In the Items pane (right side), click the Locations tab. 
3 Double-click a location in the Locations tab to add it to the project tree. 
4 Click Sites, Buildings, Floors or Rooms to expand the category.   

 

• Sites—Define the project site type. Defines the main location, and identifies the type of 
system you are designing, for example, a residence, commercial, or corporate site. 

• Buildings—Place the buildings on the site (House, Building, Office, etc.). Defines the 
buildings located on the site. For example, a residence might have a separate Garage, 
Workshop, Shed, or Pool house. A Campus might have a building for each college. 
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• Floors—Add the floors in each building (Main, Second, etc.). Lets you describe the 
various floors in each building, for example, Main and Basement or First, Second, and 
Third floors. 

• Rooms—Add the rooms on each floor (Bedroom, Bathroom, etc.). Lets you describe 
the various rooms on a floor, for example, Kitchen, Living Room, Great Room, Master 
Bedroom, Laundry Room, etc. 

Info pane 
Use the Info pane in System Design to view information about the system owner and Control4 
dealer.  

Tip: Some of the information you enter here is added to the touch screens, Control4 apps, or on-
screen navigators (More > Settings > About) in Release 2.0 or later. For example, the longitude 
and latitude  display the outside temperature on a touch screen, Control4 app, or on-screen 
Navigator. 

  

To access the Info pane: 

1 In System Design, click the Info tab. 
2 View, add or change existing information about the system owner or dealer in each box. 
3 Check and change the data periodically as needed. 

The Info pane lists: 

• System Owner information 
• Name 
• Address 
• Phone 
• Email address 
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• Dealer information 
• Name 
• Address 
• Phone 
• Email address 
• Primary Contact 
• Lead Installer 
• Original Install Date 
• Date of Last Update 

• Installation Notes—Use the Notes box to add any relevant details about a particular 
installation. 

Connections view 
Use the Connections view to define to the Control4 system the physical connections and 
addresses of each device added to the Control4 system. The connections are added 
automatically when you add the device, but you need to connect each device to other devices in 
the system. See the Composer Pro User Guide for details. 

 

To access the Connections view: 

1 Click Connections at the bottom of the left pane (see orange highlight). 

The Connections pane (left side) has two tabs: 

• Control/AV—Lets you define control and audio or video connections. 
• Network—Lets you identify devices with their IP address or network name. 

The Control & Audio Video Connections pane has three categories and several columns: 

• Categories: 
• Audio/Video Inputs 
• Control Inputs 
• Room Control 

• Columns: 
• Name—The name of the connection 
• Type—The connection category, for example, Audio  or RoomControl 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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• Connection—The connection type, for example, HDMI or Component. 
• Input/Output—Shows whether the connection is for input or output. 
• Connected To—Shows which device this connection is connected to. 

The bottom pane has several columns: 

• Device—The name of the device. 
• Name—The name of the connection on the device. 
• Location—The room where the device is located in the project tree. 
• Connections—Lists the devices connected to this connection. 

Control/AV tab 
Use the Control/AV tab in the Connections view to define the physical connections between the 
Control4 controller and other devices you add to the Control4 system, including AV signals, IRs, 
relays, contacts, and/or serial connections. 

 

To access the Control/AV tab: 

1 Click Connections at the bottom of the left pane. 
2 In the Connections pane, click the Control/AV tab. 

The Control/AV tab contains two panes: 

• The left pane displays the project tree. 
• The right pane lists the actual device connections. 

3 If you click an object in the project tree of the Control/AV tab, you are selecting either a room 
or a device to display the following types of connections in the Control & Audio Video 
Connections pane: 
• Room Connections—Lets you define the connections specific to the room which can 

include, for example, a thermostat that you can control from a touch screen, Control4 
app, or on-screen Navigator. Room connections help you customize and design the 
devices to perform specific functions in the room.  

If you select a room (for example, Family) on the Control/AV tab, the available room 
connections appear in the pane under Family (the bar just below Control & Audio Video 
Connections). The Video, Audio, or Video’s Audio End-Points and the Audio or Video 
Volume are all defined for the room.  
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• Control & Audio Video Connections—If you select a device in the Connections > 
Control/AV tab, the available Control & Audio Video Connections pane displays the 
following panes:  
• Available inputs and outputs—The top pane identifies the available inputs and 

outputs of a device to make its connections. 
• Connected items—When you select an item in the top pane, the bottom pane 

displays the available connections for that input or output. 
4 To make the actual connection, select the item in the top pane, and drag it to the associated 

item in the bottom pane. 

Note: If you select a device on the project tree and nothing appears, the device doesn’t have 
any control or AV connections; maybe it uses the network connection to communicate to the 
controller. In these cases, use the Network tab to identify this device’s network address to 
the system. See “Network Tab” below.  

The available input and output categories for the selected device display in this order: 

• Audio/Video Inputs—Shows the available audio and video inputs. In this category, the 
video connections are listed first, and then the audio connections. 

• Audio/Video Outputs—Shows the available audio and video outputs. In this category, 
the video connections are listed first, and then the audio connections. 

• Control Inputs—Shows the available input control connection. 
• Control Outputs—Shows the available output control connection. 
• Room Control—Lists the available room control connections. 

If the connections you need do not appear, you can edit the driver to create the needed 
connections. From the Driver menu (in the Composer menu bar), select Edit Existing 
Driver to open the Driver Wizard.  

Note: Editing drivers is an advanced task and is out of the scope of this document. Details about 
the Driver Wizard are discussed in the Composer Pro User Guide or you can use the Driver 
Editor. Talk to your Control4 Sales Representative to find out how to order this tool. 

Network tab 
Use the Network tab in the Connections view to display a list of all devices in the system that 
have a network connection and use a network address. Click the Identify button (for releases 
older than OS 2.2 or to re-identify a device) to establish the network connection for any device 
that communicates to the controller using TCP/IP, WiFi, ZigBee, or any other device that uses a 
network address. 

 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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To access the Network tab: 

 
1 Click Connections at the bottom of the System Design pane. 
2 In the Connections pane, click the Network tab. The Network tab displays the network type, 

for example, IP Network, along with the 
• IP Network Connections pane, and the  
• Available Devices pane. 

The IP Network Connections pane lists all devices for the selected network type. After 
identifying the network connection, the device’s address appears in the IP Network 
Connections pane under Address. 
• Buttons 

• Identify—Select a device from the IP Network Connections pane and click Identify 
to have Composer identify the device. This causes Director to listen on the network 
for the device to broadcast its network address, ZigBee address, or network name. 
Once Director is waiting for the device to identify itself, you must cause the device 
to broadcast its address on the network. The Identify window gives a description on 
how to make a device identify itself. 

• Disconnect—Select the device, and then click Disconnect to remove the 
connection. 

• Disconnect All—Click Disconnect All to remove all of the connections. 
• Columns 

• Device—The name of the device. 
• Room—The room in which the device resides. 
• Type—The device type recognized by the system. 
• Address Type—The type of address used, for example, ZigBee. 
• Address—The deviceaddress. 

After identifying the network connection, the device address appears. If a device does not have 
an address next to it, it needs to be identified to the system.  

The Available Devices pane shows the list of devices that the network has discovered. Each 
device shows up under the service type. It also displays the total number of devices found and 
the number of connected or unconnected devices of each type.  

Tip: Throughout the Control4 system, devices are identified using various types of addresses, for 
example, ZigBee, ZigBee Pro, IP, UDP, etc. These types of addresses are known as “network 
addresses.” 

Media view 
Use the Media view to select the stored or broadcast media on touch screens, Control4 apps, 
and on-screen Navigators. The Media view lets you add media selections to the Control4 
system: stored music and media collections from a network-attached storage device (NAS) or 
other devices, for example, a Dock for iPod, DVD player or disc changer, broadcasts, channels, 
and stations.  

To view and select the media from the Navigators, you first need to add and scan the media to 
the Control4 controller (for example, an EA-3 controller). With MP3, WMA, FLAC, or AAC files 
that you add and scan, you can create playlists saved to the controller (if it has a hard drive) in 
the media database. See the Composer Pro User Guide for details.  

Other Media Managers: You can use other media managers, for example, iTunes, Windows 
Media Player, and Media Monkey to stream MP3s, WMAs, or MP4s. And your customers can 
use Composer Media Edition (Composer ME) or Composer Home Edition (Composer HE) to add 
media files to Control4.  

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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To access the Media view: 

1 Click Media at the bottom of the System Design pane. 
2 In the Media pane, view the media devices. In the Media view, the left-side selections 

change the right-side views.   
The system can access and use several types of media and supports various Media Scanning 
options:  

• Stored media (e.g., DVDs) includes the possible media types that store media: 
• Controller—Lets you store MP3s, WMAs, or MP4s in the digital audio database of the 

controller (if you have a controller with a hard drive). 
• CD—Lets you store CD cover art, albums, artist ratings, and genre (Rock, Jazz, 

Country, etc.). 
• DVD Player or Disc Changer—Lets you store DVD and CD (when DVD supports CD) 

selections by viewing cover art, title, info, results, media, and disc list. 
• MP3s on Digital Audio Player—Lets you store MP3 — HDD music cover art, album, 

artist rating, and genre (Rock, Jazz, Country, etc.). 
• External or Network File Storage Devices—Lets you store MP3, WMA, MP4, FLAC,  

or AAC formats on an external hard drive, USB drive, or server. 
• Screen Saver—Lets you store the custom images to be used as screen savers on the 

Navigators. 
• Internet radio—Lets you assign a particular Internet radio station with cover art. 
• Broadcast media (for example, Cable/Satellite) includes the possible media types: 

• Direct TV—Lets you view DIRECTV channel options, including station ID, genre, rating 
and music channel. 

• Dish Network—Lets you view Dish Network channel options, including station ID, 
genre, rating, and music channel. 

• Cable TV—Lets you view Cable channel options, including station ID, genre, rating, and 
music channel. 

• UHF/VHF—Lets you view the UHF channel options, including station ID, genre, rating, 
and HDTV. 

• AM/FM/XM—Lets you scan AM, FM, and XM radio stations. 
• Playlists includes the possible media types: 

• MP3 on Digital Audio Player—Lets you play and view MP3 or MP4 — HDD music 
cover art, album, artist rating, and genre (Rock, Jazz, Country, etc.). 
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• CD—Lets you play and view CD cover art, albums, the artist ratings, and genre (Rock, 
Jazz, Country, etc.). 

• Controller—Lets you play MP3, WMA, MP4, FLAC, or AAC formats from the controller 
(if supported). 

• External or Network File Storage Devices—Lets you play MP3, WMA, MP4, FLAC, or 
AAC formats from an external hard drive, USB drive, or server. 

• DVD Player or Disc Changer—Lets you play DVD and CD (when DVD supports CD) 
selections and view cover art, title, info, results, media, and disc list.  

Possible buttons 
One or more of these buttons may appear in the center pane depending on which category you 
select: 

• Edit—Lets you edit the information for an existing album or movie. 
• New—A dialog box opens. You can add information for a new album or movie, etc.  
• Delete—Lets you remove an existing item from the list. 
• Add—Lets you add media to your system, for example, MP3, WMA, MP4, FLAC, or AAC 

files. 
• Scan—Lets you scan the selected media type or storage location for music or media 

information 
• Configure—Lets you select the storage device on which the media you're configuring 

resides. 

Right-click options 
• Right-click on a device in Stored media or Broadcast media to bring up various options: 

• Clear Media List—Use Clear Media List with caution because it clears all media from 
the device—and for a controller, you will have to start over by adding each album again.  

• Export Media List and Export Playlists—Lets you save an XML file of your lists; if you 
ever clear your project you won't have to rebuild the lists.  

• Import Media List and Import Playlists—Lets you recover your media lists after 
you've cleared your project. 

• Import DVD List from File—Lets you import an Excel list of DVD titles for a Disc 
Changer. 

• New Playlist—Lets you create a playlist which appears in the Playlists type. 
• Delete Playlist—Lets you delete an existing playlist. 
• Rename Playlist—Lets you rename an existing playlist. 

• Right-click on Playlists to display New Playlist. 
• Right-click on a playlist name to display these options: 

• Export Playlists 
• Import Playlists 
• New Playlist 
• Delete Playlist 
• Rename Playlist 

• Right-click on the individual songs in the window below the albums to edit song information 
or delete individual songs.  

Agents view 
Use the Agents view to perform more complex programming by module.  

Note: The sections that describe programming with agents are in the Composer Pro User Guide. 
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To access the Agents view: 

1 Click Agents at the bottom of the System Design pane. 
2 In the Agents pane, view the list of agents and their variables.  

Available agents include: 

• 4Store 
• Access 
• Advanced Lighting Scenes 
• Announcements 
• Communication 
• Custom Buttons 
• Email Notification 
• Intercom 
• Light Properties 
• Lighting Scenes 
• Macros 
• Media Scenes 
• Notification 
• Scheduler 
• Screen Saver 
• SNMP Configuration 
• Timer 
• Variables 
• Video Wall 
• Wakeup 

Example: The Scheduler agent lets you program using dates and times. See “Programming the 
system” or “Programming with agents” in the Composer Pro User Guide for definitions and 
examples.  

Common buttons available on some agents in the Agents view: 

• Add—Lets you add agents to your system. 
• Remove—Lets you remove agents from your system. 
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• New—Lets you create a new instance for customizing the selected agent in the Agents 
pane. For each specific instance of the agent, you provide a unique name and customize it 
according to your needs. 

• Delete—Lets you remove an existing instance of the selected agent in the Agents pane. 
• Save—Lets you save the agent-specific information. Not all agents require a manual save 

option. In most cases, the agent information saves automatically. 

Programming view 
Use the Programming view to have the Control4 system control devices by identifying to the 
system any device behavior or configuration options that you want to occur automatically. The 
Programming view lets you create a program script using the drag-and-drop method.  

Note: Programming is an advanced feature in Composer Pro. Detailed information about 
programming is explained in the Composer Pro User Guide. This section discusses some 
basics.  

All programming is based on events in the Control4 system. For example, a door that opens is 
an event. When an event occurs in the system, it can trigger other programmed actions to run. 

Example: When the Bathroom door opens (event occurs), program the Bathroom light to turn on 
(action taken). 

Another example is shown in the figure below. Note the text in the Script pane (center pane). The 
event is “When the Family > Left Dimmer top button is pushed,” and the action is “Open the 
Garage > Garage Door (Sensor).” The event came from the Events pane, and the action came 
from the Actions pane.  

 

To access the Programming view: 

1 Click Programming at the bottom of the System Design pane. 
2 In the Programming pane, view the list of Device Events (see below) and events for the 

object selected. 
The Programming view consists of several panes: 

• Programming: 
• Device Events (left pane)—Displays all devices that have associated events in 

the project tree. 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest


Composer Pro 2.10 Getting Started Guide  

42 

• <Device> or <Room> Events (left pane)—Displays the available events for the 
currently selected device or room in the Device Events project tree. If there are no 
events for that device or room, none are displayed. 

• Script (center pane)—Displays the script associated with the currently-selected event 
from the Device Events pane. You drag-and-drop an action from the <Project Title> 
Actions pane to arrange the order of actions and nest them in the Script pane. 

• Actions:  
• Device Actions (right pane)—Displays all available device options with 

associated actions you can use to write your script. 
• <Project Title> Actions (right pane)—Displays the Command, Conditionals, and 

Loops tabs. You move commands, conditionals, and loops into the Script pane 
from this pane. 

To add an action to the script: 

1 Select the device in the Device Action project tree (right pane). 
2 Select the type of action you want in the Actions pane. 
3 Click the green arrow. 
4 Drag and drop the action to the Script pane. 

• Commands tab—Use this tab to select commands (delete, add, etc.) to use for your 
script. 

• Conditionals tab—Use this tab to select conditionals ('if' statements) to use for your 
script. 

• Loops tab—Use this tab to select loops ('while' statements, etc.) to use for your script. 

Composer Pro menu options 
When you start Composer Pro and connect to Director, the menu bar appears at the top of the 
Composer screen.  

   

The menu bar provides the following menu items: 

• File—Lets you perform typical file management tasks, clear or load projects, connect or 
disconnect to the local Director, update both the Composer and Navigator software, and exit 
Composer. 

• Media—(only appears when the Media view is selected)—Lets you perform tasks regarding 
music and media lists. 

• Driver—Lets you create, copy, edit, add, or manage drivers to enable devices to work on 
the system. 

• Go—Lets you access the various Composer Pro views, including System Design (Ctrl+1), 
Connections (Ctrl+2), Media (Ctrl+3), Agents (Ctrl+4), and Programming (Ctrl+5). 

• Tools—Lets you view Network Tools, System Manager, Detective Suite, Reports (if 
installed), System Diagnostics, Account Manager, and Update Manager. 

• Help—Lets you view this document in help form plus version information. 
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File menu 
Access the File menu from the menu bar on any Composer screen.  

 

From the File menu, you can perform project file management tasks:  

• Manage the project (clear, load, back up, etc.). 
• Manage cloud backups. 
• Connect to Director. 
• Refresh Composer Pro. 
• Refresh the Navigators: touch screens, Control4 apps, or on-screen Navigator.  
• Validate Project 

The file management options apply to the files you back up on your computer called project files 
(project name plus a .c4p extension). Project files are saved by default to the My Documents 
directory under Control4/Projects. 

When you set up a Control4 system, you create project configuration information. This 
information is created live on the controller hardware, or backed up to a project file on a 
computer that lets you save specific information about each system, including devices, 
connections, configuration, programming information, and media. The project configuration is 
automatically stored on the controller hardware to which you are connected from your computer.  

Backing up the project lets you save a copy of the project on your computer which is always 
recommended whenever you make changes in Composer Pro or update the system.  

The following options are available: 

• Clear Project—Removes any project configuration from the hard drive on the controller. 
Composer Pro prompts you for a backup before erasing the project configuration information 
to present a blank project. Use this option with caution. 

• Load Project—Loads a selected project into the currently-connected controller. Composer 
Pro prompts you for a backup before it clears the project configuration information, and 
replaces it with a selected project you can browse to and load. 

• Cloud Management—Manage online backups saved from the registered system. You can 
load a cloud project to the controller, delete a cloud project, add a project to the cloud, show 
a history of cloud backups for this project, and save a cloud project to your local computer. 

• Backup to Cloud—Creates a backup of the project and saves it to Control4 online services. 
Requires a valid 4Sight subscription.  

• Connect to Director—Connects you to a Director residing on the controller. When you 
connect, project configuration information from the controller is presented to the screen in 
Composer Pro.  

• Disconnect from Director—Disconnects you from a Director. Composer prompts you to 
back up your project before disconnecting you from the currently-connected Director. This 
option is available when connected to a Director. 
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• Back up—Backs up the current project to your computer. The first time you back up your 
project, Composer prompts you for a filename. It also prompts you to back up any media 
information. If you select this option, the current project becomes an option in the File > 
Load Project list.  

• Back up As—Backs up the current project, and prompts you to enter the name of the file. It 
also prompts you to back up any media information. If you select this option, the current 
project becomes an option in the File > Load Project list. 

• Refresh—Refreshes the current Composer Pro project. 
• Refresh Navigators—Refreshes the Navigators connected to the system. Note: Control4 

for PCs and tablets must be updated in that app. Control4 for iPhone, iPod touch, iPads, and 
Androids will update if online. 

• Validate Project—Performs a check for project file integrity. 

Media menu 
Access the Media menu from the menu bar in the Media view. 

 

From the Media menu, you can create, delete, and rename playlists. You can also clear, export, 
and import media lists. A Media List is the list of media information associated with the selected 
device, for example, all DVDs with associated cover art, title, notes, etc., for each DVD in a disc 
changer.  

The media has been scanned or manually added to the media database. After you add an item 
to the media database, the cover art and information about the media can be viewed and 
selected from any of the Navigators (touch screens, Control4 apps, and on-screen navigators, 
etc.).  

The following options are available: 

• Clear Media List—Clears the media list of the selected device from the media database. 
• Export Media List—Exports a media list for the selected device from the controller to a PC. 
• Import Media List—Imports a media list from the PC to the controller. 
• Export Playlists—Exports a playlist from a controller to a PC. 
• Import Playlists—Imports a playlist from the PC to a controller. 
• Import DVD List from File—Imports an Excel list of DVD titles for a Disc Changer. 
• New Playlist—Creates a new playlist from a controller to a PC. 
• Delete Playlist—Removes a playlist. 
• Rename Playlist—Renames a playlist. 
• Tag media files—Used for OS 2.0 or later conversion of media files so all media players 

can see the same tags. 
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Driver menu 

Access the Driver menu from the menu bar on any Composer Pro screen. 

Note: You may prefer to use the new Driver Editor tool released in 2012. Check with your 
Control4 Sales Representative for details.  

 

From the Driver menu, you can create, copy, or edit drivers. You can also manage the local 
database of drivers and add other drivers from the online database as needed.  

Note: Creating a new device driver is an advanced procedure. See "Creating device drivers" in 
the Composer Pro User Guide for details. 

The following options are available: 

• Create New Driver—Launches the Driver Wizard and lets you create a new driver based on 
the typical features of a particular device type, such as DVD players, and TVs. See “Create, 
copy, and edit drivers with Driver Wizard.”  

• Copy Existing Driver—Launches the Driver Wizard and lets you copy an existing driver 
model. For example, if a driver exists for a device from a particular manufacturer, but it isn’t 
the same model, you can modify the driver for the model you need. See “Create, copy, and 
edit drivers with Driver Wizard.” 

• Edit Existing Driver—Launches the Driver Wizard and lets you modify an existing driver. 
This is mostly for testing purposes. After you create a driver, you can test the driver by 
adding it to the Control4 system to see if it functions correctly. The Edit feature allows you to 
make modifications when necessary. See “Create, copy, and edit drivers with Driver 
Wizard.” 

• Add Driver—Lets you search the local database to add a .c4i driver if it doesn't exist in the 
project. Director will load the new driver, but you will have to add the driver to the project. 
You can use Update Driver to replace an existing one. This option is used mostly with 
DriverWorks. See Composer Pro User Guide for details. 

• Manage Drivers—Lets you manage drivers in your local database and the drivers on the 
My Drivers tab. See “Manage Drivers dialog.”  

Tip: You can also right-click the driver in the project tree to: Rename, Edit Driver, Export Driver, 
Update Driver, or Delete a driver. For OS 2.0 or later, use the same procedure for Update Driver 
as with Add Driver (see above). However, Update Driver updates your driver if it IS in your 
project. Note: If the driver connection IDs change, the driver will need to be connected again. 
Double-check your connections after you update your driver. 
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Manage Drivers dialog 

Access the Manage Drivers dialog from the Driver > Manage Drivers menu item on any 
Composer Pro screen. 

 

From the Manage Drivers dialog, you can organize the device drivers (or drivers) in your local 
database. You can sort by Device Type, Name, Manufacturer, Model, Driver Status, Creator, 
Created Date, and Modified Date.  

Buttons 

• Add—Lets you add drivers from the Control4 online database to the local driver database 
(Local Database). When the dialog appears, from the pull-down menus, select the Device 
Type and Manufacturer of the device you want to download, and then click Search. Check 
the driver you want to add to the local driver database, and click OK. This adds the device 
driver to your local database. 

• Delete—Lets you delete a driver from the local driver database. 
• My Drivers—Lets you add the selected driver to the My Drivers list. In the Manage Drivers 

dialog, you select a device or use the Shift (to add multiple drivers) or Ctrl keys (to add 
multiple drivers all in a row). 

• Notes—Lets you add notes about your drivers. 
• Exit—Lets you exit the Manage Drivers dialog.  

Other options 

• Sort—Lets you sort and find drivers by column and by Device Type, Name, Manufacturer, 
Model, Creator, Created Date, and Modified Date. Click the top of each column to sort 
accordingly. Click on the column head to sort the column. 



Composer Pro 2.10 Getting Started Guide  

47 

Create, copy, and edit drivers with Driver Wizard 

To enhance device support in Composer Pro and in the Control4 system, a device needs a 
corresponding driver, known as a device driver.  

If you want to add a device to the Control4 system, and it does not have a supporting driver (or 
one that you can find in the online database), you can use the built-in Driver Wizard in Composer 
Pro to create a driver prior to setting up the device. You can access the wizard from the Driver 
menu > Create New Driver. 

 

The Driver Wizard lets you add device support to the system for infrared (IR) or serial drivers.  

For more information and example implementations, see “Overview of creating device drivers” 
and “Using the Driver Wizard” in the Composer Pro User Guide. 

Go menu 
Access the Go menu from the menu bar on any Composer Pro screen. 

 

From the Go menu, you can access the various Composer Pro views: System Design (Ctrl+1), 
Connections (Ctrl+2), Media (Ctrl+3), Agents (Ctrl+4), and Programming (Ctrl+5). This is an 
alternative to using the buttons (left side at the bottom). 

The following options are available: 

• System Design—Lets you build the project tree and identify the devices in the Control4 
system. Access this view with the keyboard shortcut Ctrl+1. 

• Connections—Lets you identify all connections (Room, Control, AV, Network). Access this 
view with the keyboard shortcut Ctrl+2. 
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• Media—Lets you add and scan stored or broadcast media. Access this view with the 
keyboard shortcut Ctrl+3. 

• Agents—Lets you set up agents for use on the system and programming. Agents include: 
Lighting Scenes, Wakeup, Scheduler, Variables, etc. Access this view with the keyboard 
shortcut Ctrl+4. 

• Programming—Lets you program devices and agents on the system. Access this view with 
the keyboard shortcut Ctrl+5. 

Tools menu 
Access the Tools menu from the menu bar on any Composer Pro screen. 

 

From the Tools menu, you can access tools for checking the device connection status. 

The following options are available: 

• Network Tools—Launches the Network Tools window. Composer shows the status of all 
network devices on the IP Network and ZigBee Network. The Network Tools window shows 
you which devices in your project are identified and communicating to the network. See 
“Network Tools dialog.” 

• System Manager—Launches a tool to connect to and configure Control4 Controller 
hardware and devices. See “System Manager.” 

• Detective Suite—Launches a suite of diagnostic tools: Bindings, Discovery, Performance, 
Programming, and ZigBee. 

• Reports—Lets you select one of the Centralized Lighting reports to run: Panel Report, 
Module Report, or Load Schedule Report. See “Reports” in the Composer Pro User Guide 
for details. 

• System Diagnostics—Assists you in gathering system information to help you determine if 
any issues encountered are configuration problems, performance issues, or potential 
defects. The System Diagnostics tool is valuable also for logging information and sending 
email to Control4 Technical Support. See “System Diagnostics.” 

• Account Services—Facilitates system registration which is required for software updates 
and to use the media services throughout the Control4 system. It is also required in 
conjunction with a customer account to enable Remote Access, which allows secure access 
to your system via the Internet. See “Account Services.” 
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Network Tools dialog 
Use the Network Tools dialog to view ZigBee devices and devices on the IP network. 

From the Tools menu, select Network Tools.  

 

The Network Tools tabs describe the following: 

• IP Network—Lists the devices on the IP network. 
• ZigBee Network—Lists information about the ZigBee devices. 

The icons denote the following: 

• Green—Indicates that an address is identified and the device is online. For example, a 
dimmer is identified and communicating to the Control4 system. 

• Yellow—Indicates that an address is identified and the device is offline. For example, if the 
System Remote Control goes to sleep, the status turns yellow. This indicates that the 
System Remote Control has been identified, but it is offline.  

• Red—Indicates that a device is not identified or has been offline for a long period of time. In 
this case, go to the Connections view > Network tab and identify the device to the system. 



Composer Pro 2.10 Getting Started Guide  

50 

The Network Tools tabs are shown below. 

IP Network tab 

 

This shows the IP devices on the network, network addresses, and status. 

ZigBee Network tab 
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This tab displays ZigBee devices, addresses, online states, and signal strengths 

You can view the ZigBee network items three ways using these radio buttons: 

 

• Room Tree—Takes the devices that are in the project and lists them. 
• Routing Tree—Takes the devices from the ZigBee server. A device may display several 

times; there may be many ways that ZigBee communicates with a device and all of those 
are listed. 

If you select the Routing Tree view and nothing appears, the ZigBee devices are not 
communicating. Under normal circumstances, you can view the display as it changes 
devices. This is due to the mesh network structure. 

• List—Takes the devices that are in the project and lists them. 

Detective Suite  
Use the Detective Suite in Composer Pro to perform diagnostic tests on the system. 

From the Tools menu, select Detective Suite. The following window appears with tabs for 
Connections and Programming. 

 

Tab descriptions: 

• Connections—Lists all the connections in the project. Lets you search by keywords, 
and expand by room or the whole house.  

• Programming—Shows programming that has been created. Can expand the event to 
include actions.  

Example pages are shown next. 
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System Diagnostics 
From the Tools menu, click System Diagnostics. Use these screens to help you diagnose 
system problems and activity. 

• Controller Performance tab—Lets you view controller performance information, including 
CPU and memory usage. Process data is listed in the bottom pane.  

 

• Controller Performance History button—Lets you view the history of CPU and memory 
performance.  
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• Controller Networking tab—Lets you view controller networking information, including 
network type, connection status, MAC address, IP address, Subnet mask, Gateway, DHCP 
status, and DNS server information. 

 

• Test Internet Connection button—Lets you test the current Internet connection. After 
viewing, click Close to exit the dialog box. 

 

• System Info tab—Lets you view system information in a tree view. Click Save To File to 
save this information. 
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• Logging tab—Lets you log system problems. 

 

This logging feature lets you: 

• Change the logging level of any of the program loggers on the operating system. Select 
from fatal, error, warning, info, debug, trace, and default. 

 

• View the selected log in real time (“Tail”). To start the tail, select the log, then click Start 
Tail. To stop the tail, click Stop Tail. 

• Open the current log file of the selected program logger. To open the log, select the 
logger, then click Open Log. 

• View all the logs available on the device at that location. 
• Click Auto Scroll Output to scroll through the log entries, or click Clear Output to clear 

all entries. 

Account Services 
From the Tools menu, select Account Services to set up a customer.control4.com account and 
register a controller, remove a controller from registration, or check in for a service connection. 
To register the controller, see Registering the Control4 system. 

You can also check the current account status and service level. Select the Status tab. You can 
view: 

• Account Status  
• Customer Account 
• Customer Email 
• Service Level 
• VPN Status 
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Update Manager 
To continue to improve our products, periodically the Control4 team needs to develop updated 
versions of Composer Pro and Director and provide those updates to you. Use Update Manager 
to update your Composer software and the system. 

To update Director: 

1 From the Tools menu, select Update Manager. 

 

2 Click Update. 

 

3 Click Begin Update.  

To update the system software: 

1 Click Update to update the system. After you begin the updates, you cannot modify your 
project. Do not remove any power cords or Ethernet cables until the updates are completed. 
You can have an email message sent to you when the update completes to notify you when 
you can modify the project again. See “Programming with agents” in the Composer Pro User 
Guide to set up notifications. 

2 To view the project, you can close the Update Manager dialog without interrupting the 
update, but you cannot make any changes. 

3 Click View Logs in the Update Manager dialog to view the update messages. 
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4 Click Cancel Pending to cancel the device downloads. This action cancels a download from 
the device. 

Note: You cannot cancel an update after the device download has finished and the firmware 
update on the device has begun. 

Help menu 
From the Help menu, you can: 

• Access the online Help topics, Index, and Search function for this Composer Pro Getting 
Started. 

• Access a PDF of the Composer Pro User Guide. Note: Use the links in the Composer Pro 
Getting Started help topics to access the PDF for the Composer Pro User Guide. 

• Check the Composer Pro and Director versions. 
• Contact Control4 Technical Support. 

 

The following options are available: 

• Chat with Support—Opens a link to contact Chat Support.  
• Getting Started Guide—Displays this Getting Started Guide 
• User Guide—Opens a link to the Composer Pro User Guide. 
• Documentation Library—Opens a link to the documentation library on the Dealer Portal. 
• Knowledgebase—Displays the Control4 Knowledgebase login. The Knowledgebase 

contains documents, articles, and other sources for reference.  
• About Composer—Displays the Composer and Director versions.  

Composer Pro Properties 
Access the Properties panes from the System Design view. 

There are three categories of properties in a Control4 system: Project, Room, and Device 
properties.  

• Project Properties 
• Room Properties 
• Device Properties 
•  

Accessing properties from the project tree 
You can use the Control4 Composer Pro Properties pane to view: 

• Devices 
• Connections 
• Status information 
• Project or customer information 
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• Configuration information for devices and rooms 

To access the Properties pane: 

1 After adding the device and making the connections, select the device from the project tree 
in the System Design view. 

2 Click the Properties tab. The properties for the device appear in the Properties pane. 

 

Properties pane 
In the  System Design view, click the project name (top level name) in the project tree to view the 
project Properties. 
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The project Properties appear when you first start Composer Pro, or any time the project name 
(or root node) is selected in the project tree and the System Design view. 

 

This option lets you enter project-specific information; for example, the project name, location, 
and ZIP Code. Composer Pro automatically enters the latitude/longitude and date/time 
information when you provide the location and ZIP Code. 

Basic Composer Pro tasks 
You can perform simple but important tasks in Control4 Composer Pro (see below), or you can 
take a deeper dive into intermediate or more advanced tasks (the Composer Pro User Guide will 
show you how). 
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Accessing the List view from the project tree 
Use the List View tab to view the devices in your project (by room). Ensure that the devices are 
added and identified to the project. 

To view the list: 

1 Click System Design. 
2 Select a room in the project tree. 
3 Click the List View tab; the status of each device associated with that room displays in the 

List View pane. 

 

Removing items from the project tree 
Use the project tree in System Design to remove devices, rooms, buildings, etc. 

To remove items from the project tree or other lists in a Composer project: 

1 Right-click the item to remove in the project tree, and then select Delete. 
2 Click Yes to confirm. 

Renaming items in the project tree 
Use the project tree in System Design to rename items. 

To rename items in the project tree or other lists in a Composer project: 

1 Right-click the item to rename in the project tree, and then select Rename. 
2 Type the new name in the object's title. 
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Clearing a project 
To erase all project configuration information, use the Clear Project menu option. 

Note: Control4 recommends that you create a backup file of your project first before you use this 
function. To back up the project, go to the File menu, and then select Back Up. Give the project 
a filename; the file saves to the My Documents folder by default. 

To clear out a project: 

1 From the File menu, select Clear Project to erase the project configuration information. 

Exiting Composer Pro 
Use the Exit command to close Composer Pro. 

To exit Composer: 

1 From the File menu, select Exit. 
2 Composer asks you if you want to back up your configuration information. 
Note: Control4 recommends that you always save a backup copy of your configuration. 

Getting project configuration information from a controller 
Use the Connect to Director link to view configuration information. 

To get existing project configuration data from a controller: 

1 Verify that your PC and the controller are connected to the same network. 
2 From the Composer Startup screen, click Local System or from menu bar, click File > 

Connect to Director (see below). The project configuration appears unless it is a new 
project. 
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Loading a project’s configuration from a computer to a 
controller 

Use Connect to Director to load configuration information. 

To load the project configuration from a computer to the controller hardware: 

1 Verify that your PC and the controller are connected to the same network. 
2 From the startup screen, click Local System, or from menu bar, click File > Connect to 

Director (see below). 

 

3 From the File menu, select Load Project. 
4 Click Yes when prompted to back up the project. Browse and select the project file. 

Example: SmithProject.c4p 

5 When you see the new project displayed in the System Design view, the project is loaded to 
the controller, and you are connected. 
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Backing up a Composer Pro project 
Use the File menu to back up your project. Control4 recommends that you do this whenever you 
change anything in a project or if you update the software. 

The File menu in the Composer screens provides the following options for backups: 

• Back Up—Backs up the current project to your PC. The first time you back up, it prompts 
you for a filename. It also prompts you to back up any media information. If you select this 
option, the current project becomes an option in the File > Load Project list. 

• Back Up As—Backs up the current project, and prompts you to enter the name of the file. It 
also prompts you to back up any media information. If you select this option, the current 
project becomes an option in the File > Load Project list. 

Any time you exit Composer by clicking File > Exit, Composer Pro asks you if you want to back 
up your project. If you've made changes, it's a good idea to do so. 

Backing up and loading from a virtual to a local or remote 
Director 

Use the Connect to Director option to back up a Director. 

To back up and load configuration information from a virtual Director to a local Director: 

1 From the Composer File menu, select Connect to Director. 
2 When prompted, click Yes or No if you want to back up the media information. 
3 A Directors dialog box appears listing the available Director IP addresses. Select the 

address of the controller to which you are connecting. 

 

4 Click Connect. You are now connected to a local Director. 
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Backing up a project's configuration and media 
Use Composer Pro to back up project information. When connected to the controller, changes 
are immediate. 

To save a project configuration to your computer, and then use the Back Up and Back Up 
As options: 

1 From the File menu, select Back Up. 
2 Type a filename to back up the project, or use the same name, if you prefer. 

 

3 When prompted, click to select the options to back up media information and personal 
information, then click Save. 

Validating the project 
Use Composer Pro to validate the integrity of the project file. You can validate a project while 
connected to a Director or Virtual Director. 

To check project integrity after connecting to Director (or Virtual Director): 

1 From the File menu, click Validate Project. 

Composer displays any errors. If no errors are found, nothing else will be displayed. 
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Connecting to a Director 
Each Control4 controller (for example, an EA-3) ships with pre-installed Director software. The 
Director communicates with Control4 and third-party products to enable home automation so 
devices can communicate with each other and Director. 

To configure or update a Control4 system, start Composer Pro and connect to a Director. 

 

Note: If a Composer license is associated with this product, a 'Renew Composer Registration' 
screen may appear before you can connect to Director. If it does, you must type your email 
address, password, and then click Renew. 

On the Composer Startup screen, you can connect three ways depending on how you want to 
connect. 

In Composer Pro, click the box that represents one of the following options: 

• Virtual System 

You cannot identify network connections, test device control, or set up media using this 
method. See the Composer Pro User Guide for information. 

• Local System 

You can set up and design the project, make connections, add media, and program the 
system using this method. 

• Remote System 

You can do everything as if you were hooked up to the Local System using this method. 

Select a connection option, and then refer to the following sections for specific instructions about 
how to connect. See “Start Composer” earlier in this document for details about each method. 

http://www.control4.com/customers/resources#documents
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Connecting to a virtual system 
If you connect to a virtual Director, you are working in Virtual Director mode. This means you are 
not connected to the Control4 controller and the home network, and changes are not 
automatically saved in real time to the Control4 controller. 

Saving changes when working virtually 
The only way your changes are saved is to manually use the Back Up As or Back Up option 
from the File menu to save the project file. The project file saves by default with a .c4p extension 
to your My Documents directory on your computer. 

Using Virtual mode 
After you have designed and set up a system in Virtual Director mode, you can load the project 
to the controller. 

The Load Project option is available from the File menu. This mode is useful, for example, if you 
are using a laptop PC, and you can't connect to the network.  

• If you change the project, you can connect to the network and synchronize your changes to 
the controller when you're ready.  

• If you design and set up a system in Virtual Director mode, you can later load the project to 
the controller. In the File menu, the Load Project option is available for synchronization. 

To connect to a virtual Director: 

1 Start Composer and connect to a Director. 
2 At the Composer Startup screen, click Virtual System. Virtual Director lets you work in 

Composer while disconnected from a Director. Composer opens to the main Composer view 
in Virtual Mode. 
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The System Design view appears by default. 

 

Connecting to a Director on a local network 
When you connect to a Local Director, you are making 'live' changes on the controller. Every 
time you connect to the Director on that controller, your project opens. 

Tip: You also have the option to make a backup of the project on your computer by using the 
Back Up As or Back Up option from the File menu to save the project file. When you back up a 
project file, it is backed up by default to the My Documents directory on your computer. 

To connect to a Director locally: 

1 From the desktop, double-click the Composer x.x.x icon. 
2 At the Composer startup screen, click Local System. Local Director connects you to the 

home network while working in Composer Pro. 

 

3 From the Director dialog box, select the Director’s network address for the controller you are 
setting up, and then click Connect. 
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4 Make a note of the network’s IP address. Composer Pro opens to the Composer System 
Design view. 

  

Setting up Remote Access 
Use a Control4 Navigator to enable or disable Remote Access. This feature lets you access your 
Control4 system for updates using the Internet from a remote location. Note: You can also set up 
Remote Access when you create an account at customer.control4.com.  

Prerequisites 

• Register the system at customer.control4.com. This process can be completed by the 
installer or homeowner as long as the system a Navigator, touch screen or on-screen 
configured in the system. 

To set up Remote Access for OS 2.6 or later: 

1 At one of the touch screens or on-screen Navigators, select Settings > Service 
Connection. 

2 Select Yes under Remote Service. 
Notes:  

• After you enable remote access, if the user has a 4Sight subscription for this system, 
then the user can enter their email address and password and securely log in to their 
Control4 home network from any Internet connection in the world.  

• When the user logs in, the homeowner can use the Web Navigator to monitor and 
control their lights, change their temperature (warm or cool the home remotely), or 
check whether any doors or windows were left open. You or the user can refer to this 
Internet information in the Control4 System User Guide.  

• If this system and controller are registered on customer.control4.com, the system is 
accessible for remote access (without a 4Sight subscription) after a request by the 
Control4 Installer or Control4 Technical Support representative has been made to 
access the system. After OS 2.4.0, this check-in is no longer required to initiate a 
remote service connection. 

http://customer.control4.com/
http://www.control4.com/customers/resources#documents
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Connecting to a Director using Remote Access 
If you connect to a Remote System, you are making “live” changes to a remote system controller, 
where changes are communicated over an Internet connection rather than a local network 
connection. This type of connection is not available, however, until the initial configuration and 
registration are completed.  

Note: The customer may revoke access rights through my.control.com at any time, but this is not 
recommended as it interferes with routine Control4 updates. 

Requirements 
• The customer must be registered at customer.control4.com and remote access must be 

enabled. (See “Registering the Control4 system” or “Register the controller from a 
Navigator.”) 

• A PC with Composer initially installed must be in the same local network as the controller 
when remote access is set up. 

Before you can use the Remote System option, you must configure the system to support remote 
access (see “Registering the Control4 system”). 

Connecting using Remote Access 
To connect to a Remote Director: 

1 Using a PC with Composer Pro installed, verify that the PC has an Internet connection. 
2 From the desktop, start Composer. 
3 At the Composer startup screen, click Remote System. Remote Director connects you to 

the home network while working in Composer from a remote location.  

 

4 Enter your Email Address and Password in the Account Name dialog box. This should be 
the login information from your account on your dealer my.control4.com account. 

https://my.control4.com/Default.aspx
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5 When the Select Remote Account dialog box appears, select the account you want to 
access, and click Connect. 

  

If the account name doesn't appear under Name, click Add to add the account name, and 
Username (Email address) and Password if they are different from your dealer account login 
credentials, and click OK in the dialog box that appears. This is the Account Name you 
created during registration at customer.control4.com. After you do this, select the account 
from the Select remote account dialog box, and click Connect. 

 

 

The next screen shows that your account, the User Email Address, and the Password are 
being verified. This may take several minutes to complete as it is accesses a remote 
connection. 

When authenticated and connected through the Remote Access service, a list of Directors 
available for connection appears. 

6 Select the Director you want to connect to, and then click Connect. 

When connected, Composer opens and the main Composer view connects to the controller 
remotely. Composer functions normally as if you were connected to Local Director, allowing you 
to configure, program, and troubleshoot the Control4 system. 

Ensuring that Director and Composer are compatible 
Verify that the Control4 controller software (Director) and the Composer software are on the 
same version before beginning to design a project, or any time you use Composer to ensure the 
best communication between the two. 
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To check compatibility: 

1 In the Composer menu bar, click Help > About Composer.  
2 From the dialog that appears, compare the Composer and Director version numbers. For the 

Control4 system to run properly, these numbers must match. If they don't match, update 
Composer and/or Director to get to the same version. See the Composer Pro User Guide for 
information about updating your system, or see “Update Manager.” 

Example: 

Composer version: 2.6.0.439267 

Director version: 2.6.0.439267 

Note that the two versions in the screen below are the same.  

 

Designing the Control4 system 
Become familiar with the Control4 Composer Pro design options before you start to build your 
first project and project tree. The project tree represents the hierarchy of locations (sites, 
buildings, floors, and rooms) AND devices in each room. You will add all types of controllable 
devices to the Control4 system, including audio/video, multi-room audio, lighting, motorization, 
sensors, relays, and more. 

Here are some sections that might interest you as you prepare to design a system: 

• “Introduction to Designing a Control4 System” 
• “Ways to Create a Project in Composer” 
• “Purpose of Device Drivers” 
• “Adding Items to the Project Tree” 
•  “Using Composer Views to Build a Project” 

In most cases, it’s good to make a list of the actual devices to be used in the project, the 
manufacturer and the model number. You will need this information as you build the project. 
Also, before you start, create a plan for your project. 

Tip: It might be worth your while to check out some cool project management programs called 
"Smart Office" and "Control Integration" by Simply Reliable. These products help you manage 
your projects, from creating home automation proposals to integration of devices, into a 
Composer project. There's also a service called Blackwire Designs (blackwiredesigns.com) that 
can help with design and networking infrastructure. 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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Introduction 
Designing a Control4 system in Composer Pro is similar to designing a house. You start with the 
plan; then you build the foundation; you build the framework; and then you add the electrical, 
plumbing, walls, carpets, paint, etc. to finish the home.  

To give you a 'bird's eye view' about how to design and implement a Control4 system: 

• Create a plan. This includes the devices to be used, where they will reside in the home, and 
how the network will be set up. For example, to plan a Centralized Lighting project, you’ll 
need to obtain the blueprint plan and where all of the lighting devices and panels will be 
located in the home, ensure that all of the lighting legs are clearly identified, determine what 
types of loads will be controlled by the centralized system, and where the panels will be 
located (see Control4 University on control4.com for more information). 

• Physically install and connect the Control4 and third-party devices that need to communicate 
to the network. Note: Many Control4 or third-party devices may be installed already. 

• Physically connect these devices to each other and to the controller(s) used in the project so 
they all communicate with the controller and the home network. 

• In the Composer Pro software, build the project tree using the System Design view. This 
includes adding objects to the project tree that represent the physical buildings, rooms, and 
devices. Note: You can connect a physical device, and then add it to Composer one at a 
time if you prefer. 

• In Composer Pro, identify and virtually connect all of the devices. In addition to the hardware 
connections, you have to connect your devices the same way in the Composer software 
also. 

• Customize the behavior of the devices in Composer and on the Navigators. To customize 
the devices for specific functions, you program events and actions, Lighting Scenes, agents, 
and so on for your customers' needs. Many custom functions can be performed on the touch 
screens and on-screen Navigators. See the Control4 System User Guide and Control4 
Quick Start Guide for more information. 

Designing a fully functioning Control4 system includes these major steps: 

• Use Existing or Custom Device Drivers. Every device in the Control4 system needs a 
corresponding device driver so that controlling the device is possible. When designing and 
implementing a Control4 system, each time you add a device to a room, a corresponding 
device driver must be added to the Composer project in the project tree. Device drivers for 
Control4 products come pre-installed in Composer. In addition, device drivers for hundreds 
of third-party devices are available through an online database, and easily can be added to 
the project when the driver is available. If a driver for the model you need does not exist, you 
can use the Driver Creation Wizard (available through a menu option) or DriverWorks (a free 
add-on utility) to create a custom driver. See the Composer Pro User Guide for details. 

Tip: If you can't find the device driver you need, you can start with an existing device driver, 
and modify it for your device using the Driver Creation Wizard or Driver Editor.  

• Make the connections. In the Composer project, you identify all physical device 
connections to the Control4 system, including control, AV (audio, video), network, and other 
connections (there are several types of connections). Identifying a device to the system 
means the controller acknowledges that the device exists on the home network and can 
communicate with it and the other devices in the network. Use the Connections view in 
Composer for this.  

• Register the system at customer.control4.com. Control4 strongly recommends that you 
register each system you install at my.control4.com to maintain the system software easily 
through online downloads. Only registered systems can use all of the media services 
available. In addition, system registration is one of the essential steps in enabling remote 
access to the system.  

http://www.control4.com/customers/resources#documents
http://www.control4.com/customers/resources#documents
http://www.control4.com/customers/resources#documents
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• Set up the media. You identify existing media on the system using the Media view in 
Composer. The Media view helps you search or scan for movies, videos or music in stored 
media and auto-generate a list of local broadcast channels, stations, playlists, etc. After you 
have searched for or scanned in the existing media, you can test Media access through the 
navigation devices (also known as Navigators).  

• Configure the properties. You will want to set individual device properties according to 
your customers' wishes, because most devices have some settings that can be configured 
(for example, dimmers that ramp up and down). 

• Program events and actions. You define interactions between system events and the 
actions of other devices. For example, when a projector turns on, it can trigger other devices 
(lights, etc.) in the Home Theater to dim down or turn off. 

• Create the variables and agents for use in programming. Advanced programming setup 
options are available to you, including string, Boolean, device properties, variables, delays, 
and agents. Using these options, you can configure, for example, a 3-way switch, turn 
equipment on and off with proper delay times, create Lighting Scenes, and perform other 
desired programming between devices. Advanced programming is discussed in the 
Composer Pro User Guide. 

• Customize the Navigators. You complete the registration process and enable Remote 
Access. You can work with your customers also to set up screen savers and other custom 
functions on their Navigators.  

• Centralized Lighting design. Designing for a Centralized Lighting system is a bit more 
complicated than designing a typical control system. For details about Centralized Lighting, 
see the Centralized Lighting Products section on the Control4 website, and take available 
training classes.  

Purpose of device drivers 
Every device in the Control4 system needs a corresponding device driver so the device can be 
controlled by the Control4 system. When you design a system in Composer, the corresponding 
device driver is added to the project each time you add a new device to a room.  

Device drivers for Control4 products come pre-installed in Composer. Device drivers for 
hundreds of third-party devices are available through an online database and can be added 
easily to the project. If a driver for the model you need does not exist, you can use the Driver 
Wizard to create a custom driver.  

Note: Creating a device driver is an advanced skill in Composer. For detailed information about 
how to create a driver, see “Creating device drivers” in the Composer Pro User Guide. 

Adding items to the project tree 
To add items to the project tree or other lists in a Composer project, use one of these methods: 

• Double-click—After selecting a location in the project tree, double-click an item in the Items 
pane to add it to a selected location in the project tree. 

• Drag and drop—Drag and drop items (such as building, floors, rooms, devices, etc.) from 
the Items pane to the desired location in the project tree. When dragging-and-dropping 
items, drag the item directly on top of the room or location (such as site, building, floor) in 
the project tree (left pane) where you want the item to reside.  

• Hover—After you’ve added an item to the project tree, you can hover over it for a pop-up of 
important identifying information. 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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Example: Drag a device (for example, a television) directly on top of the Theater room to ensure 
it resides in that room. 

 

Building a project in System Design 
Using the System Design view, you create the foundation of the Control4 system by building a 
project tree in System Design. 

Tip: Before you begin to build the system, you may want to assign to all of the devices that will 
be used in the Control4 system unique and meaningful titles if you used a planning worksheet. 
That way, they will be easy to identify when you connect them to the home network. 

To build a new project tree in System Design: 

1 Start Composer Pro and connect to a Director. A new project opens in the System Design 
view by default. 

2 In System Design, click the Properties tab, and enter the following information: 
• Name—Enter homeowner’s name or other project name. 
• ZIP Code/Postal Code—In Lookup, enter the homeowner’s ZIP Code. 
• Latitude and Longitude—Populated automatically when you enter a ZIP Code or 

postal code. 
• Date—Update as needed. 
• Time—Update as needed. 
• Click to select the project tree. 

3 Add the locations to the project tree, including sites, buildings, floors, and rooms. 
Composer Pro requires this location hierarchy: Site > Building > Floor > Room. The devices 
will be added to the rooms later. 

Tip: You do not have to add every level in the hierarchy manually. If you begin building your 
project tree by adding a room, Composer Pro automatically adds a Building and Floor object 
for you. You can easily rename these objects in the tree later. 

a In the project tree, select a location (site, building, or floor) where a room exists. 

Example: The Master Bedroom is on the Second floor, so you would click Second to 
select it. Go to the Items pane and double-click or drag-and-drop Master Bedroom to 
copy it to the project tree. 

b In the Items pane > Locations tab, double-click the room you want to add. The room 
displays in the selected location in the project tree. The room is given a default name, 
but you can rename it any time by right-clicking on the object in the project tree, and 
choosing Rename. 

c Repeat these steps until you have included all of the floors and rooms on each floor in 
the home to complete your project.  
Example: Add three rooms to the Main floor which already has a few rooms and the 
Garage.  
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d Click Theater in the Items pane > Locations tab to add a Home > House > Main > 
Theater to the project tree. 

e Select Main in the project tree, and then click Bedroom to add it to the Main floor. 
f With Main still highlighted in the project tree, click the Front room to add it to the Main 

floor. 

 

4 Click the room and add the devices. For example, add the controller in a room of the 
project tree.  

Important: Ensure that the devices you select have exact and meaningful titles; for 
example, “Wireless Dimmer” could be renamed to East Wall Wireless Dimmer for easy 
recognition later. If you have several devices, such as wireless dimmers, in the same room 
give them a unique name.  

Tip: You can right-click the driver in the project tree to: Rename, Edit Driver, Export Driver, 
Update Driver, or Delete a driver. Use the same procedure to Update Driver as for Add 
Driver (see “Driver menu”).  

Note: If you installed this version of Composer on a computer that has an older version of 
Composer (OS 2.2 or earlier), right-click in the white space below the My Driver tab and 
select Restore Default List. This action updates the My Drivers list.  

a Click the room in the project tree. 
b From Items pane > My Drivers tab, double-click a controller to move it to the selected 

room (all devices to be added must be selected from the My Drivers tab).  



Composer Pro 2.10 Getting Started Guide  

75 

Example: Select the Theater room, and then double-click the controller. The controller and 
associated Digital Audio objects appear in the project tree. Digital Audio is a component that 
resides on the controller, but shows up as a separate object in the project tree. Digital Audio 
provides the functionality to play media. 

 

5 Add the Control4 lighting devices and Navigators to the selected room if they reside there.  
Example: Add the following devices to the Theater room.  

a Double-click Wireless Dimmer, and then rename it to Dimmer. 
b Double-click Wireless Switch, and then rename it to Light Switch. 
c Double-click Wireless Outlet Switch, and then rename it to TV Outlet Switch. (This 

will be used to control the power on a TV that uses an On/Off toggle switch.) 
d Double-click System Remote Control SR-250. 
e Double-click 6 Button Keypad.  
Note: If you have a wireless touch screen, add it now to your project. 

6 Add all applicable audio and video devices to the selected room.  
Here are three examples to follow.  

Example 1: Add a receiver to the Theater room  
a Select the Theater room in the project tree. 
b Double-click Receiver in the Audio/Video section of the My Drivers tab. A dialog box 

displays with Local Database selected and the receiver drivers that are currently 
available in the local database. 
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c Select the receiver’s manufacturer and model. In the dialog box, select Online 
Database, select the manufacturer Harmon Kardon, and then double-click 
AVR230[IR]. 

 

Note: The Receiver object is added to the tree, along with a Tuner. The next time you add a 
receiver to this project, the AVR230[IR] will appear in local database driver list.  

Example 2: Add a TV to the Theater room  

a Select the Theater room in the project tree. 
b Double-click Television in the Audio/Video section of the My Drivers tab. A dialog box 

displays with local database selected, and the TV drivers currently available in the local 
database. 

c In the dialog box, select Online Database, select the manufacturer Samsung, and then 
double-click TX-P1430[IR]. 
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Notes:  

• The UHF/VHF object is added automatically to enable you to scan for UHF/VHF 
broadcast channels. 

• The next time you add a TV to this project, the TX-P1430[IR] appears in the local 
database driver list. 

Example 3: Add the DVD player to the Theater room  

a Select the Theater room in the project tree. 
b Double-click DVD in the Audio/Video section of My Drivers tab. 
c In the dialog box that appears, select Online Database, select the manufacturer Apple, 

and then double-click DVD Apple TV [IR]. 

 

7 Add Motorized devices or Sensors, if applicable, to the selected room.  
Example: From the My Drivers tab, add a Motorized Screen and a Door Contact Sensor 
to the Theater room from the online database. 

a Select Theater in the project tree. 
b In the My Drivers tab under Motorization (scroll down), double-click Motorized Screen. 
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c In the My Drivers tab under Sensors (scroll down), double-click Door Contact Sensor.  

 

8 Add an HVAC, if available, to the selected room.  
• Add a Security Panel, if available, to the selected room. 
• Add an IP Camera, if available, to the selected room. 
• Add a pool and spa controller, if available, to the selected room. 
• Add Network File Storage, if available, to the selected room. 
• Repeat Steps 6–8 as needed for each room.  

9 Identify and the test the connections. See the Composer Pro User Guide for configuration 
and connection information. 

Composer Pro design methods 
Planning a Composer Pro project: Create a plan 

Before you start to work on a new Control Composer project (especially if you're new at it) it's 
best to create a plan.  

Tip: Some of our dealers use a variety of design tools, for example, AVSnap, Microsoft Visio, 
AutoCAD, and conceptdraw.  AVSnap seems to be the cheapest and the most popular tool. 

Here are some suggestions:  

• If you haven't done so yet, we strongly recommend that everyone who installs and 
configures Control4 products take the 'Tech 1 Training' class provided by Control4. Send an 
email message to training@control4.com or go to http://dealer.control4.com/dealer/training 
(dealer login required) to find out how to enroll. 

• Sign up for the Control4 Online Training sessions. 
• Check out the Control4 Troubleshooting Guides, Best Practices, and other materials on the 

Training site in the dealer portal. 
• Check the Control4 Knowledgebase and dealer forums. 
• Review the documentation on the Control4 dealer website.  
• Check out the Training  web page on the dealer website. 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
mailto:training@control4.com
http://dealer.control4.com/dealer/training
https://support.control4.com/kb/
https://forums.control4.com/loginflat.aspx
http://dealer.control4.com/
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Home automation design methods 

Prerequisites to creating a design 
Before you begin to create a design for a Control4 system, it’s a good idea to create a plan so 
you know all of the devices in each room, how many rooms there are, how many floors, 
buildings, the home network structure, and so on. 

Guidelines of system design 
Consider the following items before you start to design a project for a Control4 automated home. 

• Use existing or custom device drivers—Every device in the system needs a 
corresponding device driver so the Control4 system can control the device. When designing 
the system, each time you add a physical device to a room, for example, a DVD player, the 
corresponding device driver must be added to the project in the project tree. Device drivers 
for Control4 products are installed in Composer Pro. Device drivers for hundreds of third-
party devices are available through an online database, and can be added easily to the 
project when the driver is available. If a driver for the model of a device does not exist, you 
can use the Driver Creation Wizard (available through a menu option) or DriverWorks (a 
free add-on utility) to create a custom driver. 

• Connect and identify the devices to the network—In the Composer project, you identify 
all physical connections to the system, including control, AV (audio, video), network, and 
other connections. Use to the Connections view in Composer to complete this task. 

• Register the system at my.control4.com—Control4 recommends that you register each 
system you install at customer.control4.com so you can maintain the system software using 
the online downloads. 

Important: Only registered systems can use all of the media services that are available to 
Control4 customers. System registration is one of the essential steps in enabling remote 
access to the system. 

• Set up the media—Identify any existing media on the system using the Media view in 
Composer. The Media view helps you search or scan stored media and auto-generate a list 
of local broadcast channels and stations. After you’ve searched or scanned in the existing 
media, you can test the Media access through the navigation devices (also known as 
Navigators), and you can create playlists also. 

• Configure properties—Manage a device’s settings in the Properties pane. 
• Program events and actions—Define interactions between system events and the actions 

of other devices in the Programming view. For example, when a projector turns on, it can 
trigger other devices in the Home Theater to turn on or off causing an event to occur. 

• Create variables and agents for use in programming—Advanced setup options are 
available in Composer: string, Boolean, device properties, variables, delays, and agents. 
Using these options, you can configure, for example, a 3-way switch, turn equipment on and 
off with proper delay times, create lighting scenes, and other customized programming 
between devices.  

• Customize the Navigators—Complete the registration process and enable remote access. 
Work with your customers to set up screen savers and other custom functions. 

http://customer.control4.com/
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Using Composer views to build a project 
Composer Pro lets you set up a Control4 system using different Composer views for different 
tasks. In Composer views, you can add devices, make connections, set up media, and program 
the system using devices and agents. 

In Composer views, you have the flexibility to follow any setup path you choose as long as a 
controller is the first device you add to the project. 

Note: Before you start to create a project, you will need to understand how to use the views. 

To use Composer views: 

1 Start Composer Pro and connect to a Director. 

 

2 The System Design view appears by default. Notice that the System Design, Properties and 
Items panes appear in the screen. Each view has its own set of panes. 

Making and testing the connections 

Connecting the hardware 
Before you can design and build a project in Composer Pro, first start by installing the devices 
and connecting the cables on every device that will be a part of the Control4 system. Otherwise, 
the devices will not be acknowledged by Composer and Director. 

If you purchased equipment from Control4, ensure that you’ve carefully read the installation or 
setup instructions and/or user guides included in the box. These instructions will show you how 
to attach the cables, and in some cases, how to set up and use the device in Composer Pro. 

Testing the device connections 
When you test a Control4 device connection, you are ensuring that the connection is successful 
so you don’t encounter any problems with devices not functioning later on. You must perform this 
action for customer satisfaction. For information about identifying devices and device 
connections, see the Composer Pro User Guide. 

The following types of connections may need to be tested on the Control4 system: 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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• Network connections—Defines the devices that use a network address. Network 
connections include IP and ZigBee or ZigBee Pro devices. 

• Control connections—Defines the control connection between a device and the controller. 
Control connections include contacts, relays, serial, and IR-controlled (infrared) devices. 

• Audio and video connections—Defines the devices that have audio and/or video signals. 
• Room connections—Defines the video, audio, or video/audio end points and the 

video/audio or audio volume for the selected room.  

Testing network connections 
In the Connections view, click the Network tab > IP Network. The list of devices appears. 

Make sure there is a network address for every item in the list. If there is not, see “Cannot 
identify the device to the network” in the Composer Pro User Guide. 

Testing control and AV connections 
In the Connections view, click the Control/AV tab. This list of devices appears. 

Testing room connections 
In the Connections view, click the Control/AV tab. This list of devices appears in the Room 
Connections pane. 

Registering the Control4 system 
Every system must be registered at customer.control4.com to maintain the system software 
through online downloads, and to use all of the media features in the system (for example, the 
Control4 online media database for scanning music). System registration is also one of the 
essential first steps in enabling remote access to the system. 

After you complete the initial Control4 system setup (adding devices to a project, identifying them 
automatically for devices released with OS 2.3.0 or later, and making software connections for 
each device), you are ready to register the system and set up the media. “Setting Up the Media” 
is discussed in the Composer Pro User Guide. 

You can register the system either from Composer or by using a Navigator. See the sections 
below. 

Register the system at customer.control4.com 
Control4 recommends that you register each Control4 system you install at 
customer.control4.com to maintain the system software easily through online downloads. Only 
registered systems can use all of the media services available.  

System registration, which includes setting up a customer.control4.com account, is required to 
use most of the media services that are available in the Control4 system, for example, scanning 
media into the system (so that you don’t need to manually add individual music files).  

You can register the system now through Composer, or later through a Navigator if you 
customize the Navigator. You may have already registered the system in Composer to set up 
media. If not, you can register the system using any Internet connection and one of the 
Navigators that is connected and identified. 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
http://customer.control4.com/
http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
http://customer.control4.com/
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Register the controller from Composer Pro 
Composer Pro lets you register the controller to a customer account without having to log in to 
the customer’s account. You can now create a new account and register the controller in one 
step, register to an existing account found under your dealer of record, or manually register the 
controller using the 10-digit code from the customer’s account page under Controller registration. 

To set up a new customer.control4.com account and register this Control4 system: 

1 In Composer Pro, go to Tools > Account Services. 
2 Click the Add New Account tab to create a customer.control4.com account and start the 

registration process for the user. 

 

3 Complete the Account Information form for the user, and then record the Account Name and 
Email Address for the user’s future reference. 

4 Click Add Account to create an account for this Control4 system and register the controller 
to the new account. 

  

To register the system to an existing customer account: 

1 In Composer Pro, go to Tools > Account Services. 
2 Click Select Account and select the existing account you wish to register to in the list of 

Customer Accounts. 
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Note: If the existing customer account does not show up in the Customer Accounts list, have the 
customer log in to their account and verify their dealer of record is pointing to your dealer 
account. 

To manually register the system to an existing customer account: 

1 In Composer Pro, go to Tools > Account Services. 
2 Click Manual Registration. 
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3 From the customer.control4.com account page, copy the 10-digit registration code found 
under My Devices > Controller Registration > Register New Controller. This code is time 
sensitive and must be used within 10 minutes. It provides a temporary code used to 
exchange the security parameters and create a secure connection between 
customer.control4.com and the controller. 

4 On the Account Services page, click the text box and paste the 10-digit registration code 
in the box. 

5 Click the Register button on the Account Services page in Composer (now enabled) to 
complete the registration. The Current Status changes to 'Registered.' 

Register the controller from a Navigator 
Important: To complete the registration from a Navigator, the Navigator must be installed, 
connected to a controller, and identified in the system.  

To use a Navigator to set up a customer.control4.com account and register this system: 

1 Go to customer.control4.com. 
2 Click New Account at the top of the screen. 

 

3 Complete the Create Consumer Account form for the user according to the instructions on 
the page, and then record the Account Name, E-mail Address and Password for the user’s 
future reference. Note: It’s important that the information entered here is the customer’s, not 
the dealer’s. 

4 Click Create Account to create an account for this system. 
5 On the Complete Registration page, click Yes. 
6 On the Controller Registration Confirmation page, copy or write down the 10-digit 

registration code displayed. This code is time-sensitive and must be used within 10 
minutes. It provides a temporary code used to exchange security parameters, and set up 
the ability to create a secure connection between my.control4.com and the controller. 

7 Go to the Navigator's main menu (Home Page), and press Settings > Registration.  
8 Select the text box in Enter Code, and then enter the 10-digit registration code. 
9 When you are finished, tap Done. 
10 Select Activate. When activation is completed, the user can use all media services, such as 

the online media recognition service. 

http://customer.control4.com/
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11 (Optional) While you are here, you may want to enable Remote Access. Select Service 
Connection > Yes. This allows Control4 access for system updates and is a required step 
in enabling user remote access. 

Setting up a 4Sight subscription 
Use the Internet to set up a 4Sight subscription. This feature enables a Control4 system user to 
log in to the Internet and manage their Control4 system on the web. Consumers will need 4Sight 
to use Anywhere Access also. 

Note: 4Sight subscriptions are sold separately. 

Prerequisites 

1 Design and set up the project. 
2 Register the Control4 controller and the system owner. 

When a 4Sight subscription has been obtained for the Control4 system, this setup can be done 
by the homeowner or installer. The installer or a Control4 representative should be able to 
provide information about how the homeowner can set up a customer account. The Control4 
System User Guide or Account Setup provides that information for the homeowner.  

To set up a 4Sight subscription at customer.control4.com: 

1 Obtain a 4Sight subscription code for the system (sold separately). 
2 Log in to customer.control4.com using the homeowner/user email address and password. 
3 From the My Account tab, select the Subscriptions view. 
4 Enter the 4Sight subscription code provided by your Control4 representative, and then 

click Activate. 

Tip: Scroll down and view Account Subscriptions to see which subscriptions you already have. 

http://www.control4.com/customers/resources#documents
http://www.control4.com/customers/resources#documents
http://www.control4.com/residential/products/resources/
http://customer.control4.com/
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Managing and assigning Composer Pro licenses 
Use my.control4.com to set up additional Composer Pro Licenses for dealers and their 
employees who use Composer Pro. You must do this before you run Composer Pro.  

Notes 

• Controller registration is separate from a Composer Pro License.  
• You cannot assign Composer Pro Licenses to consumer accounts; these are for dealers and 

their employees only. 
• Thirty days after the license is activated, you will be notified to renew the license. You can 

choose not to, or you can extend the period another 30 days. 

Prerequisites 

• Composer Pro must be installed or updated to the current release. 
• A valid dealer account must be set up. 
• A valid dealer sub-account that the dealer account manages can also be used. 
• Access to my.control4.com. 

You can find comprehensive information about this subject in Managing Dealer Accounts in 
my.control4.com. 

Where to go from here 
This Control4 Composer Pro Getting Started guide gave you: 

• An overview of Composer: how to install and start it, how to access a Director, and includes 
a preview of the Composer interface (views, menus, properties, panes, etc.). 

• An overview of how to start designing your project with suggested tools. 
• An overview about connections and how to test devices. 
• How to register the Control4 system. 
• How to set up a 4Sight subscription. 
• How to set up Remote Access. 
• Examples about how to build a system in System Design.  

More detailed and advanced sections (Composer Pro User Guide) are outside the scope of this 
document but you can find them on the Dealer Portal. 

The advanced sections give you specific details about: 

• Setting Up Media 
• Creating Device Drivers 
• Making Connections 
• Verifying Connections 
• Configuring Devices 
• Configuring Properties 
• Basic Programming 
• Advanced Programming 
• Customizing Navigators 
• Installing Devices 
• Troubleshooting the System 

http://www.control4.com/docs/product/dealer-account/dealer-instructions/english/latest
http://www.control4.com/docs/product/dealer-account/dealer-instructions/english/latest
http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
http://dealer.control4.com/
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Contacting Control4 technical support 
Should you encounter any problems while using Composer Pro, please contact Control4 
Technical Support for assistance. 

• Phone: 1-888-400-4072 
• E-mail: support@control4.com 

Other resources 
Also check out the Control4 Forums or Knowledgebase. 

Project build example using system design 
The following sample project steps you through the creation of a Control4 project using 
Composer Pro. This example assumes that you’ve already saved the project as a backup, and 
covers basic device additions to the project, but not connecting or identifying the components. 
This example project: 

• Includes a theater room 
• Adds keypad and electrical interfaces 
• Adds AV components 
• Adds a touch screen  

Adding a controller 
When setting up a system, first add the controller to the list. You must attach a controller to each 
television you add to the Control4 system. 

To add a controller: 

1 Start Composer and connect to a director. 
2 In the System Design pane’s project tree, select the Theater room.  
3 In the Items pane, click the My Drivers tab. 
4 In the Controller category, double-click Home Controller HC250. The controller is added to 

the project’s Theater room.  

mailto:support@control4.com
https://forums.control4.com/register.aspx
http://kb.control4.com/
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Note: If you installed this version of Composer Pro on a computer that already had an older 
version of Composer Pro, right-click anywhere in the My Driver tab, then click Restore 
Default List. The My Driver list updates. 

 

Adding keypad and electrical interfaces 
After adding a controller, you can add dimmers, switches, keypads, outlets, and a remote control. 

To add keypad interfaces:  

1 In the System Design pane’s project tree, select the Theater room.  
2 In the My Drivers tab, do the following:  

a Under Lighting > Light (v2), double-click Adaptive Phase Dimmer to add it to the 
project, and  then rename it to Dimmer in the project. 

b Under Lighting > Light (v2), double-click Switch, and then rename it to Light Switch. 
c Under Lighting > Light (v2), double-click Wireless Outlet Switch, and then rename it to 

Television Outlet Switch. 
d Under User Interface, double-click System Remote Control. 
e Under User Interface, double-click Configurable Keypad. 

Tip: Use a descriptive name for items added to a project. You can right-click and select 
Rename, or you can begin typing right after the item is added. For example, if you have two 
dimmers in a room, you could name one “Wall Dimmer” and the other “Ceiling Dimmer.” This 
helps you clearly identify items later when making connections. 

Adding AV components 
After adding interfaces, you can add the main components of the home theater. 

To add AV components:  

1 In the System Design pane’s project tree, select the Theater room.  
2 Add a receiver to the room: 

a In the My Drivers tab, under Audio/Video, double-click Receiver. 
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b In the dialog box that opens, select Online, select the manufacturer Harmon Kardon, 
then double-click AVR230[IR]. The receiver is added to the project.  

  

3 Add a retracting movie screen to the room: 
a In the My Drivers tab, under Motorization, double-click Motorized Screen. 

 

b Under Sensors, double-click Door Contact Sensor. 
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4 Add a TV to the room: 
a Under Audio/Video, double-click Television. 
b In the dialog box that opens, select Online Database, select the manufacturer 

Samsung, then double-click TX-P1430[IR]. The TV is added to the project.  

 

The Cable TV and UHF/VHF objects are also added to the project, to enable you to scan for 
cable and broadcast channels. 

 



Composer Pro 2.10 Getting Started Guide  

91 

5 Add a DVD player to the room:  
a Under Audio/Video, double-click DVD. 
b In the dialog box that opens, select Online Database, select the manufacturer 

Samsung, and then double-click DVD HD841[IR]. The DVD is added to the project. 

 

6 Add online TV to the room: 
a Under Audio/Video, double-click DVD. 
b In the dialog box that opens, select Online Database, select the manufacturer Apple, 

and then double-click AppleTV [IR]. Apple TV is added to the project. 
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Adding a touch screen 
After adding AV components, add a touch screen. 

To add a touch screen: 

1 Under User Interface, double-click InfinityEdge 7” Touch Screen. The touch screen is 
added to the project. 

 

Finishing the project 
After adding devices to your project, you will still need to identify, connect, and test the devices. 
For more information, see Connecting and verifying devices in the Composer Pro User Guide. 

http://www.control4.com/docs/product/composer-pro/dealer-user-guide/english/latest
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Glossary 
 

# 
4Sight: An Internet service that provides a connection to the 
home automation system any time and from any place 
worldwide. 

A 
AAC: Advanced Audio Coding. A successor to the MP3 format. 
A standard, lossy compression and encoding scheme for digital 
audio. Touts better sound quality. 

action: An activity that occurs when an event prompts it to do 
so. 

agent: In Control4 programming, agents provide the ability to 
perform complex programming by using functional modules. 
There are various types of agents; for example, 
Announcements, Email Notifications, Scheduler, Lighting 
Scenes, Wakeup, etc. 

Anywhere Access: Lets users access and control their 
Control4 systems remotely using a mobile device or tablet 
anywhere in the world. 

AV: Audio Video 

C 
CD: (Compact Disc) - An optical disc that stores digital data. 
This format is compatible with Control4 products. 

client: A software or hardware device that communicates to a 
server for feedback from the server via an application for the 
user. 

command: A ‘do’ statement; actions the Director 
communicates to a device. 

Composer: The Control4 software used to design and define a 
Control4 home automation system. 

Composer Pro: Composer is used to set up and configure 
Control4 devices to communicate with each other in a home 
automation system. 

conditional: An ‘if’ statement that asks true/false questions 
which are acted upon in Composer programming. 

configuration worksheet: Used in Composer software training 
to design and configure a project in Composer. 

connection: Devices that are bound or linked together in 
Composer so they can communicate with each other. 

contact: Contacts are generally used to monitor the status of 
something (door, window, water sensor, etc.) and can be 
connected through a security panel or directly using a Control4 
controller or Contact/Relay Extender. Contacts connected to a 
Control4 controller or Contact/Relay Extender can be 
configured either as NC (normally closed) or NO (normally 
open). 

Control4 App: A Control4 graphical Navigator that runs on 
mobile devices or a PC or tablet.  

Control4 system: A home automation system designed and 
developed by Control4. 

controller: The main device that makes home automation 
possible. There may be multiple controllers within a Control4 
system. The controller that runs Director is referred to as the 
primary controller. 

D 
Detective Suite: A set of tools that perform diagnostics tests on 
the Control4 system. 
device: A component that requires a device driver; code that is 
used to allow the Control4 system to work with that device. 

device driver: Every device in the Control4 system needs a 
corresponding device driver to control the device. 

DHCP: DHCP (Dynamic Host Configuration Protocol) - A 
protocol used between a network client and a DHCP server 
(usually a router or access point) that dynamically assigns IP 
addresses from a pre-defined list to clients on a network. 

Director: Each Control4 controller ships with pre-installed 
Director software (Linux based) embedded in the device. The 
Director communicates with Control4 products and third-party 
products to enable home automation and interaction of devices. 
Director runs the Control4 devices. Composer Pro is the 
software used to connect to and program a system Director that 
resides on a controller. 

DriverWorks: The DriverWorks SDK is used to create two-way 
drivers for audio video (AV) and non-AV devices. 

DVD: (Digital Versatile Disc) – A media format for video and 
data storage. 

E 
end point: The end point is the final point (device) on the 
defined path over which audio and/or video content is routed to 
a room. An example of this would be a TV or receiver. 

Ethernet: Uses Ethernet category 5 (CAT5 or CAT5e) wiring to 
transfer data. Ethernet uses a star network topology that allows 
multiple points to communicate to a single point. The Speaker 
Point® uses Ethernet to communicate to the Control4 controller. 
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event: An action; used to trigger Composer programming when 
programming Control4 devices. 

F 
file format: A format used by applications to store/read files. 

FLAC: Supported by Control4 since software release 1.8, this is 
a free, open source, lossless audio codec format that supports 
tagging, cover art, and fast seeking. Audio is compressed with 
no loss in quality. 

G 
gateway: (router)- Provides a means of communicating 
between two separate networks. 

H 
home network: A network installed in the customer’s home 
that provides an Ethernet or wireless connection so that 
Control4 devices can communicate with each other. 

home automation system: The Control4 system: a line of 
home automation products that communicate with each other 
over Ethernet, WiFi, or ZigBee for a total home automation 
experience. 

I 
IR: Infrared light—Some network devices can be controlled by a 
wireless remote control that uses pulses of infrared light to send 
commands to the device. 

L 
Linux: An operating system used by several Control4 devices. 

List Navigator: Menu options that are visible on a System 
Remote Control. 

Live Connection: A term used in Composer Pro to indicate an 
actual connection to the network. 

Loop: A type of conditional in programming; a ‘while’ 
statement; for example, “while the sprinklers are on…” 

M 
Media Manager: Media information (metadata) is stored in 
Media Manager and the media database on the primary home 
controller, which will permit users to view the media from the 
Navigators. 

MP3: A music format that makes streaming audio available. 

MP4: An audio and video format. Can also store images and 
subtitles. 

N 
Navigator: A Control4 Navigator used with the Control4 system 
to control lights, music, videos, etc. Navigator is software that 
the customer interacts with using a System Remote Control, on-
screen Navigator, Control4 apps, or touch screen. 

O 
On-Screen Device: Allows you to select the controller in a 
room that controls the source for the on-screen display. 

P 
playlist: A list of songs compiled in a list. The list can be 
compiled by songwriter, album, song type, or any combination 
of the above. 

Power Over Ethernet (POE): Network cabling that provides 
Ethernet connectivity and device power over a single cable. 
Commonly used for Control4 devices. 

programming: A machine-readable artificial language used to 
express computations that can be performed by a device. 

project tree: A tree view in Composer where the project is 
layered by the larger branches (Home, Office, etc.) and then the 
lower branches (floor, rooms, etc.), and finally to the leaf level 
(drivers). 

R 
ramp rate: The rate that a dimmer ramps up its voltage. 

relay: An electrical switch that opens and closes. A relay is 
controlled by another electrical circuit. 

remote access: The ability to access a device from a remote 
location. 

Remote Director: Connects you to the home network while 
working in Composer from a remote location. 

retrofit: The ability to set up a home automation system in an 
existing structure or home. Compare this with new building 
construction. 

RJ-45 jack: An eight-pin jack used to connect CAT5e network 
cables to Ethernet devices. 

router: See gateway. Functions similar to an AP but with 
additional functionality for controlling the network; for example, 
coordinating traffic between different networks. 

S 
SNMP: An Internet-based protocol for networked systems that 
require monitoring of network-attached devices in case 
administrative intervention is required I those devices 
malfunction or go offline. SNMP uses a set of standards to 
manage networks. 
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serial-controlled device: Serial-controlled devices with an RS-
232 interface and control protocol often have a higher level of 
controllability than IR-controlled devices. Examples of serial-
controlled devices are projectors, multi-disc DVD changers, etc. 

switch: An extension of a router that adds more Ethernet ports 
to support additional devices or clients on the local network. 

system event: An action that causes another action; for 
example, if a projector turns on, it enables the other devices in 
the system that work with the projector. 

system remote: System Remote Control 

System Remote Control: A Control4 System Remote Control 
is a universal solution that replaces remote control devices from 
other manufacturers, and includes programmable buttons. This 
System Remote Control can access on-screen (graphical) 
Navigators. 

T 
touch screen: A touch screen is a home automation system 
Navigator that controls the home’s lighting, music, videos, and 
other devices on the home automation system. 

U 
UI (user interface): The preferred term is Navigator. The 
Control4 interface used with Control4 devices to control home 
automation, for example, touch screens, Control4 apps, or on-
screen Navigators. 

universal remote: Universal remote control. A third-party 
remote control that can be programmed to replace other 
remotes in the home so that only one remote is needed, 
replacing all others. A Control4 System Remote Control is a 
type of universal remote control. 

USB: (Universal Serial Bus) - A connector format used with 
USB drives that connect to a USB port on Control4 devices. 

V 
Virtual Connection: A term used in Composer Pro to indicate 
a connection outside the network. 

Virtual Director: A connection to a virtual controller only (a PC 
is the Director host rather than the controller). Projects created 
or edited here are benign until the saved project is loaded onto 
a controller. 

W 
WiFi: Uses bi-directional wireless technology to transfer data. 
WiFi (wireless fidelity) devices “connect” to each other by 
transmitting and receiving signals on a specific frequency of the 
radio band using a wireless access point. This technology uses 
the star network topology. WiFi uses high bandwidth 802.11. 

wired network: Uses Ethernet Category 5 (CAT5) wiring to 
send and receive data between devices connected to a 
network. 

wireless access point: A router extension with an antenna that 
communicates with WiFi devices and clients in the home. A 
wireless hub that connects to the wired network, and distributes 
the wireless signal. 

wireless switch: Uses ZigBee. UL listed dimmer. Single or 
multi-gang. Has an air gap to cut power. 

WLAN: Wireless local area network. 

Z 
ZigBee: A wireless network that uses bi-directional wireless 
mesh network technology to transfer messages from one 
device to another. Unlike a star network topology where devices 
can only send messages to each other by sending them first to 
a single central device (which then delivers the message to the 
recipient device), a mesh network topology allows the devices 
to forward messages from one device to another, thereby 
extending the effective range of the network. Uses low 
bandwidth 802.15.4. 250 devices are allowed per controller but 
Control4 recommends a maximum of 125. 

ZigBee Pro: The 1.1 version of ZigBee that provides 
improvements in standardization by: allowing more 
interoperability with other Control4 devices, support for home 
automation profiles, and improving the scalability of multiple 
ZigBee access points. 
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Index 

10-digit registration code, 90 
4Sight 

setup, 91 
AAC, 37 
Account Services, Tools menu, 59 
Action, programming, example, 40 
Actual playlist options, 38 
Add Driver option, 44 
Add locations, to project tree, 16 
Agents, 85 

options, 39 
pane, 40 
view, 14, 38 
view, from Go menu, 47 

AM/FM/XM, 37 
Audio and video connections, 87 
Audio end point, 21 

devices, 21 
Audio volume, 21 
Audio/Video inputs, 33 

Connections view, 35 
Audio/Video outputs, 35 
Available Devices pane, 36 
Available inputs and outputs pane, 35 
Back up Composer, 13 
Back up, media information, 67 
Backup, 43, 67 

project, 65 
Backup As, 43, 67 
Backup to Cloud, 42 
Basic tasks, 63 
Bindings 

Detective Suite, 54 
Broadcast media types, 37 
Build project 

Composer views, 86 
Build project, system design, 77 
Buildings, Locations tab, 31 
Cable TV, 37 
CD, 37, 38 
Certified Only, 30 
Chat with Support, 61 
Clear Media List, 38, 43 
Clear Project, 42, 65 
Cloud Management, 42 
Command tab, 41 
Communication options, installation, 8 
Composer 

back up, 13 
exit program, 13 
older versions, 80 
register system, 88 

same version as Director, 76 
startup screen, 12 
views, 14 

Composer HE, 36 
Composer ME, 36 
Composer Pro 

activation, 7 
defined, 5 
interface, 11 
User Guide, 5 
views, from Go menu, 46 

Conditionals tab, 41 
Configuration information, 62 

load, 66 
Configure properties 

system design, 78 
Connect hardware, 86 
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Search tab, 27 
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Director, 5 
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Virtual mode connection, 71 
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Disclaimer, 2 
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Update system, 60 
Upgrade Composer Pro, 9 
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Virtual Director, 12 
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Windows 7, 5 
Windows Media Player, 36 
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